Read about OpenEMR's Response to the COVID-19 Pandemic at https://www.open-emr.org/covid19/

Loss of convenient features

Somewhere between version 5.0.1 and version 5.0.2 patch 3 there are a number of convenient features that seemed to get lost. You can no longer click on a time on the calendar to schedule a visit for the current patient you are looking at. When you are printing a report, clicking on the first box of a given visit no longer clicks all the associated boxes for that visit and you have to click them all separately. If you are documenting a prescription sent through another carrier such as veradyne/allscripts you have to fill in all of the somewhat redundant boxes before it will let you save the script. When you are posting a payment it will not allow you to post for a carrier that doesn’t pay anything to allow you to advance to either billing a secondary payor or the patient. In mine it also still posts them all with a date of 00-00-0000.
There a re work arounds for most of this but they just take more time which is not the basic idea.

Hi @cverk -
See the pics after all this, but both the OpenEMR dev and public demos with either the demo data or a newly created patient (respectively) will allow clicking on calendar time to make the appointment for a selected patient in the customary manner, no workaround needed.
Re: the report- which report?
I can’t address the other issues you raise since neither the OEMR demo nor my system are set up as yours is.
Best- Harley

Of course, Billy Smith is the provider on this calendar…
image

image

Thanks for your reply. I found by just marking out this clause in sl_eob_invoice I fixed on of the issues that bothered me:
// Check if save is clicked with nothing to post.
// if (allempty && delcount === 0) {
// alert(<?php echo xlj('Nothing to Post! Please review entries or use Cancel to exit //transaction')?>);
// return false;
// }

I found that using simplified prescribing in globals mostly resolved the prescription issue. I am still baffled by the calender and the posting date of 0000-00-00 but will continue to work on it.

patch(3) tested and I can’t recreate time clicks. All work okay for me!

this looks like it’s missing the id attribute

this code could be cleaned up some, like removing the comment

will give it a shot

Thanks for looking at these. The report I referred to is on the medical record dashboard for a patient under the report tab. It is used to put together records you may wish to say send to a consultant. You now have to click every little box individually for each visit which is redundant. I tried it on the demo and it is the same.
I still have no idea why my calender will not pull up the popup to schedule or change an event. I am using Windows 10 with the newest xampp, but I cannot see why that should matter. I made sure the browser would allow popups for openemr also without help. Trying to sub in old calender files just crashes the whole thing and repeating sql_upgrade and sql_patch did not help. I cannot find a relevant administrative setting that seems to work. If an idea comes to mind, please let me know.

Hi, Turn on User Debub All in Globals->Logging
log out then back in and try your calendar again. Most errors php or javascript will popup in display.

I verified this on 503 so prob true on 502. At least the select all sub report should work so i’ll fix this for patch 4.

These are the error I can find listed. The las one as a popup if you click a time on the calender. Interestingly if I change my global appearance view from tab to frame the calender works again. It however works on the demo in both views.

Deprecated : Array and string offset access syntax with curly braces is deprecated in C:\xampp\htdocs\openemr\library\patient.inc on line 574
Deprecated : Array and string offset access syntax with curly braces is deprecated in C:\xampp\htdocs\openemr\library\calendar.inc on line 33
TypeError:where.jQuery is not a function URL:http://localhost/openemr/libray/dialog.js?v=51 Line:530 Column:26 Error object:"{}"

This is the one that breaks popup.

/libray/
Is this mistyped by you or did that come from the error popup?
[/quote]

What PHP version?

Sorry that was my typo. It wouldn’t let me cut and paste. Does it help that I am using php 7.4

I check and it says 7.4.4 on the calender test system

Something is preventing JQuery from loading. I turn off ~E_DEPRECATED so that may be why it is working on my 7.4 setup. Either you can disable that warning or i’ll test with it on. I still need to fix those though…

Okay @cverk i’ve recreated and see the issues. It’s compatibility issue of 502/php7.4.
I believe we recommend turning off E_DEPRECATED & E_STRICT reporting for 5.0.2 for several reason but if you add ~E_DEPRECATED & ~E_STRICT to your php.ini you should be okay.

I use:
error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED & ~E_STRICT & ~E_USER_DEPRECATED

1 Like

Still got the same error but again only in frame instead of tab mode. I may just need to introduce my office to the tab interface. I am glad to see it may be a php 7.4 problem that needs to be fixed for everyone instead of something weird on just my setup.

I still can’t break calendar click on times even w/ Deprecated errors.
Anyway, yes on the tabs because starting in 5.0.3, frames are gone. Even 5.0.2 has some issues w/frames and we just can no longer support frames. Newer browsers where the deciding factor here.
If you want to try this pre patch 4, it has some encounter and calendar fixes that may help.

removed for new patch

I will get Reports squared away for ya though.

Okay, i’ve recreated your dialog issue in frames so I can get to the bottom of that at least. May be tomorrow.

good point on the error reporting. Updated this:
https://www.open-emr.org/wiki/index.php/FAQ#What_are_the_correct_PHP_settings_.28can_be_found_in_the_php.ini_file.29.3F

@cverk @stephenwaite
I think I resolved all these issues. If i’d realized sooner that this was a frame UI issue, would have had done couple days ago. I fixed up a patch for testing it includes everything for patch(4) thus far.
For this issue

  • Fix for calendar events dialog in Frames UI
  • Patient Report sections select all check fix.
  • Plus all the neat new encounter stuff

Please let me know if this resolves issues. Thanks
PR #3590
Temp Patch:
502_prepatch_4.zip is outdated. see Loss of convenient features

1 Like

Thank you. My office was happy to trade working on learning the tabs interface today in exchange for getting the calendar to work correctly. Next I still need to figure out why posting payments still comes up with a posting date of 00.00.0000. Interestingly if you go back after posting and look at the patients ledger, the correct date is there.