Zend Framework not found

infrastructure

(Sherwin Gaddis) #1

The requested URL /interface/modules/zend_modules/public/Installer was not found on this server.
Ubuntu 4.15.0
PHP 7.2.19
A little history, this is an installation that I moved from windows to Linux last year. I am starting to build a module. I thought first it must be the permissions. I went down that road for two hours plus. Changed all the permission. Same results. I ended up downloading the Linux code from SourceForge
and replacing the entire modules folder. Nothing changed. Are there other dependencies that I am missing? The error log is no help as no errors about this are being produced.

@brady.miller @zhopenemr

Errors


(Jerry P) #2

make sure you have mod rewrite turned on and .htaccess is allowed!

also, really not worried about php notices.


(Sherwin Gaddis) #3

Thanks for pointing me in the right direction. It was not the mod rewrite. It was a bad config.

Changed this:
<Directory /var/www/>
Options FollowSymLinks
AllowOverride None
Require all granted

to this:
<Directory /var/www/>
Options FollowSymLinks
AllowOverride All
Require all granted

Restarted apache and it loaded zend modules.

Thanks!!!
Sherwin


(Jerry P) #4

FYI, turns on allowing .htaccess. For all RESTful calls in OpenEMR we use .htaccess for redirects to the api. This includes app api’s(standard and FHIR), Zend modules(ccda e.t.c) and portal.
e.g.
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l
RewriteRule (.*) index.php?_REWRITE_COMMAND=$1 [QSA,L]

However, i’m not sure this is the most secure option and perhaps
<Directory /var/www/htdoc/openemr> or whatever your pathing is and should be restricted to your virtual host or site config for instance.

Good grief! I’m awfully chatty today :slight_smile:


(Sherwin Gaddis) #5

I will take this and run with it. It is good to have dialog with another as view can be over looked thinking to oneself.