Upgrade to Vr 5.0.2. in Windows 10 problem with PHP

question

(Nerik Cavalier) #1

I cannot upgrade to Vr 5.0.2. in Windows 10. On upgrade I received this error message

“PHP version needs to be at least 7.1.2.”


(Nerik Cavalier) #2

error%20scrshot


(Daniel) #3

create a php file in the htmldocs folder called phpinfp.php and in the file put

<?php phpinfo(); ?>

Then load this webpage. It will give you all the info you need to see what version you have. How long ago did you first install XAMP?


(Nerik Cavalier) #4

Thank You Daniel,

We did update XAMP like 10 month ago, in time when we upgraded to 5.0.1(6). We removed our old XAMP we used from 2012, and reinstalled new 5.0.1(6) for Windows with XAMP package. It’s actualy current version.


(Daniel) #5

There is a chance that you do not have all the PHP libraries as well. When you look at the phpinfo() from the web application you can see what version of PHP your webserver is using:


(Paulo Afonso Medeiros Kanda) #6

If you are using openemr in windows localhost,
perhaps I can help with this path:

Install is very tricky in windows!!

your specific error ocurred because openemr version 5.0.2 needs at least php 7.1.2 will all libraries = easiest way to get them:
You must upgrade xampp + apache+ mysql (which in fact is Maria). Update all of them installing the last version of xampp.

I tried a lot and finally I updated openemr from 5.0.1 to 5.0.2. At the beginning I had the same error message and various other message errors.

while in 5.0.1 I used xampp control panel to go to mysql phpmyadmin and removed all the passwords from all databanks and I give all permissions to all users.

only them I created dumpfile.sql (as follows)

Then I followed step by step:
https://www.open-emr.org/wiki/index.php/Dual_Upgrade_of_OpenEMR_and_XAMPP_in_Windows

rename xampp folder to xampp_old

install new xampp version and inside folder:

C:\xampp\htdocs\

install openemr5.0.2 but rename folder to openemr.
it results in:

C:\xampp\htdocs\openemr

and tried to restore the dumpfile.sql
but received a message that openemr databank doesnot exist

I came back to xampp control panel > mysql >phpmyadmin

and create an empty openemr databank

but it didnt work because there was an error:
user doesnot exist.

I came back to xampp control panel > mysql >phpmyadmin

and create an user openemr with all privileges

copy configuration from

old sqlconf.php to the new one ( in folder C:\xampp\htdocs\openemr\sites\default)

*****atention****atention:

the new sqlconf.php comes with an error at the end of the file:

//////////////////////////
//////////////////////////
//////////////////////////
//////DO NOT TOUCH THIS///
$config = 1; /////////////
//////////////////////////
//////////////////////////
//////////////////////////
?>

the last " ?> " is missing = correct it ( in fact this shoud be the cause of your error)

only them… the browser interface was available and I could finally update my databank and use openemr5.0.2.

It was a try an error journey

when openemr is working you can adjust the passwords and permissions.

delete xampp_old folder
backup copying xampp folder.


Previously to dumpfile.sql restore,
openemr upgrade requires via http://localhost/phpmyadmin/ :

the creation of :

  1. an empty openemr databank
  2. an user openemr (or other name You have created) and,
    the correction of:
  3. a missing ?> in sqlconf.php among other config details.

good luck!

Paulo Kanda


(Nerik Cavalier) #7

Thank You Daniel and Paulo for your help
Problem resolved !