Do you use or administer OpenEMR? Take the General Satisfaction Survey to help improve the product

Site ID is missing from session data! 2021 Version 6.0.0(1)

Hi,

I see several threads about this in the past, but none helps me.
My copy is on Ubuntu 18.04 LTS server and it’s up to date and patched up.
I am a newbie and the initial setting up was done including the external database.
I get the error after not attending openEMR for a few seconds,
and lose all what’s being typed in. I don’t think it’s normal. Could you help?

It sounds like your session time out is very low, go to Administration > Globals click on the security link on the sidebar and check the idle session timeout seconds.

This is what determines how long you can be logged in before the app terminates your session, this is done for security reasons you don’t want to leave a workstation unattended with patient data visible on the screen so be very careful how long you set it to.

I hope that helps I don’t even know if this might be your problem but that’s exactly what it sounds like to me.

Good luck.

Thanks for responding. Idle Session Timeout Seconds has been 7200 ( 2 hours)

and I probably logged in more than 2 hours, but I didn’t count.

Will see if the same error happens again, within the 2 hour time frame.

No, it’s not that. I even increased the limit to 72000 seconds

and I still have the same problem.

Is the permission on sessions directory like this OK?:

wxr-xr-x 66 root root 4096 Mar 31 17:16 …

drwxr-xr-x 5 root root 4096 Feb 13 00:33 modules

drwx-wx-wt 2 root root 4096 Apr 3 12:09 sessions

hi @lulu3507o, could you paste a screenshot of the error please? thank you

I was just editing an encounter and it happened again:

i think it only happens during the editing of ‘encounter’.

I lost all encounter SOAP notes from this.

also I am not sure if it’s related but when I clicked “Managing Modules”

just randomly because I am frantic, it shows an error message at the bottom

Internal Server Error

The server encountered an internal error or
misconfiguration and was unable to complete
your request.

Please contact the server administrator at webmaster@localhost to inform them of the time this error occurred,
and the actions you performed just before this error.

More information about this error may be available
in the server error log.

thanks @lulu3507o, are you editing this part of the encounter?

No, I didn’t lose the SOAP note. I logged out and back in again and it’s there,

but the error happened this time when I was clicking around and when I clicked

“New Encounter Form” and canceled it.

if you’re running Ubuntu server, where is localhost? Are you running Ubuntu desktop?

that is the first thing I edit when I open the new encounter.

but that’s not the time when the error happened.

the error sometimes happens when I edit SOAP note.

this time when I clicked the 'new encounter’button

Yes, I am running a self-installed KDE on top of Ubuntu server,

and I open Firefox inside KDE. so localhost is where I have

the browser, openEMR and database/apache.

ok thanks, are you using just one firefox tab to access OpenEMR?

definitely all the time

try clearing browser cache.

Just clicked "visit summary’ edit and it happened again!

Site ID is missing from session data!

I did clear the browser cache but it doesn’t get rid of the error message.

I have to log out and in again to make openEMR useful.

This is a major problem for me so far. It just happens too often.

If there is a hope to remove this error on a clean wipe-reinstall Ubuntu-openEMR,

I’d do it, but there are not many resources I can use.

I am considering using a low cost EMR now… it starts with O also.

not able to reproduce @lulu3507o, have you checked your php settings?

yes, it checks out fine for php 7.4 BUT

somehow 8.0 is there and I don’t know when it was installed.

php 7.2 was with Ubuntu Server 18.04 and I had to upgrade it to 7.4

to work with openEMR 6.0.0 and that’s the only thing I did.

Does having the 8.0 directory in /etc/php means now it’s 8.0?

OH MY !!!

I have 8.0!!!

jhk@hp-elite:/etc/php/8.0/apache2$ php --version

PHP 8.0.3 (cli) (built: Mar 5 2021 07:53:56) ( NTS )

Who did this!! I’ve been updating the system as the KDE asked me to.

as you see php.ini for php 7.4 was edited on 2/9

hk@hp-elite:/etc/php/7.4/apache2$ ls -la

total 84

drwxr-xr-x 3 root root 4096 Feb 9 23:35 .

drwxr-xr-x 5 root root 4096 Feb 9 22:51 …

drwxr-xr-x 2 root root 4096 Mar 7 22:13 conf.d

-rw-r–r-- 1 root root 73355 Feb 9 23:34 php.ini

php.ini under 8.0 is not edited for openEMR

What do I do now?

you can have mult versions installed just set a default

after all that PHP default set back to 7.4 and reboot,

I still get “Site ID is missing from session data!”

while editing SOAP note for a while and click “save”

this is just too much…