Read about OpenEMR's Response to the COVID-19 Pandemic at https://www.open-emr.org/covid19/

Setup.php does't run on new install of Open EMR on CentOS 8

I am trying to install Open EMR 5.0.2 on a new install of CentOS 8. MariaDB installed and configured. Apache responds to an internet log on, as does the PHP info page. Open EMR downloaded. When I try to log on to localhost/openemr I get a blank page with localhost/openemr/setup.php?site=default in the search bar. Can anyone help with this?

Welcome @angus,

Sorry you’re having trouble getting up and running. Can you check your PHP log files and see if there’s any specific error messages that may help diagnose this?

/var/log/php-fpm/www-error.log
[24-Feb-2020 20:27:07 UTC] PHP Fatal error: Interface ‘JsonSerializable’ not found in /var/www/html/openemr/vendor/tightenco/collect/src/Collect/Support/Collection.php on line 19
[24-Feb-2020 20:27:10 UTC] PHP Fatal error: Interface ‘JsonSerializable’ not found in /var/www/html/openemr/vendor/tightenco/collect/src/Collect/Support/Collection.php on line 19

Command:

sudo dnf install php-json

and restart server.

Command:

sudo systemctl restart httpd.service

Thanks Luis. I installed php-json and then several other dependencies and managed to run the login script. However, after all looked good and install script ran, on loging in I got “Site ID is missing from session data!”

Hi Angus.
Here are solutions regarding that

Hi Luis. I saw this post but being a complete nube, I didn’t know how how to access the Security tab in globals.

So. Could you make it work?

No. I wasn’t able to follow these instructions because I don’t know how to access the “Security tab in globals”. The PHP log is as follows if that helps.
/var/log/php-fpm/www-error.log
[26-Feb-2020 17:18:44 UTC] PHP Warning: session_start(): open(/var/lib/php/session/sess_ayXQF9r,MH1dWVZwND0mjVbiBCNJa05159jnVI6WJECCeukW, O_RDWR) failed: Permission denied (13) in /var/www/html/openemr/src/Common/Session/SessionUtil.php on line 78
[26-Feb-2020 17:18:44 UTC] PHP Warning: session_start(): Failed to read session data: files (path: /var/lib/php/session) in /var/www/html/openemr/src/Common/Session/SessionUtil.php on line 78

You have downloaded the latest version ?.
Has the last patch been applied? https://www.open-emr.org/wiki/index.php/OpenEMR_Patches
Please clear your browser’s cache and try again
regards

Thank you for your help and advice. I have downloaded and installed patches as suggested. Deleted browser’s caches. I still get the same “Site ID is missing from session data!” message.
Best wishes

Same error message error on the php log

I wasn’t able to address the issue of the settings in the security tab in globals. Could you tell me how to do this?

hi @angus , I’d be willing to bet that CentOS has some super security setting or module installed in it’s OS that is not allowing apache/php access to the php session directory at /var/lib/php/session/

(if you are unable to write/store sessions then php’s world will crumble)

Hi. Can anyone help me with how to edit the settings for the session under “Security tab in globals”? This is the one piece of help I haven’t been able to follow.

@brady.miller should i try reproducing it?

Yes fine. Let me know how it goes.

In Openemr as Administrator: Administration/Globals/Security.
In the database (using phpmyadmin, HeidiSQL or other). Database openemr-> globals Table

Is that logged on to openemr as administrator? Problem is I can’t log on.

@im-Amitto , That would be great if you are able to test on CentOS 8. This sounds more like a php/apache permission issue that will break all php software that requires sessions.