Preparing for 7.0.1 release

We are beginning to prepare for 7.0.1 release. Can track the progress of the release here:
QA and Release Process - OpenEMR Project Wiki


The countdown is starting! Planning release of 7.0.1 in about 1-2 weeks. Please test and report bugs. Testing vehicles include online demos, packages (built daily), and docker (built daily).

For the testing demos, go here:
Development 7.0.1 Demo - OpenEMR Project Wiki

For the daily built testing packages (and install/upgrade instruction sets), go here:
OpenEMR Downloads - OpenEMR Project Wiki

For the daily built testing docker (also set up to do the auto-upgrade), go here:
OpenEMR Downloads - OpenEMR Project Wiki

Also, if you want yourself added to the acknowledgements, just let me know (these also end up in OpenEMR’s acknowledgments page in the About page):
OpenEMR Acknowledgments - OpenEMR Project Wiki

And let me know if we are missing anything on the planned Release Features:
Release Features - OpenEMR Project Wiki


I found a bug, when I set in Admin/Encounter Form NOT Show Date of Service on Encounter Form, it does not record the meeting date correctly, which should be the current date:

In Demo

1 Like

In the patient->new/search menu, the search window is inverted PID (external ID or PUBID) with the patient’s ID.

1 Like

Used the no-data demo:

I was able to create a new patient, new appointment, LBF, encounter and progress note, fee sheet, add an insurance company, and a clearinghouse, and generate a claim…all good.

It would be nice to have a fake clearinghouse to send a fake claim to. @brad

I did not add ICD10 codes but did get all the appropriate errors after generating the claim without ICD10.


1 Like

Thank you Sandra. Also I’m working on getting demo credentials for etherFax for our demos anytime.

1 Like

Wait, let me do the portal too!

Ok, so I created credentials, went on the portal, sent a chat, signed consents.
Went back to openemr, replied to the chat, and works great.
I audited the signed documents and downloaded them into the patient’s chart, that worked great too, but after I did that, the little portal icon on the upper right disappeared!
Logging out and back in is not bringing it back! Not sure what happened.

It’s here:

test patient scheduled for today

I’m interested to know if anyone has attempted to upgrade a server from the 7.0.0 to 7.0.1 instead of a fresh install like the demo servers do. I ended up having to clear my browser cache in order to get the provider interface to work (after logging in). Logos are still not showing but I’m investigating that issue right now.

If anyone has tested an upgrade with an existing installation, I’d like to know if this is user error, or if we have a wider problem we need to resolve.

1 Like

If there aren’t any audits or mail notifications then the Portal Notification drop down will not display.
Do a new doc and audit to see.

I did a pull and rebuild with only issue I saw was the logo is gone with the alt text in it’s place.

I had to do a docker-compose restart to get the images to show up again. As the logo locations got moved around, the docker images don’t detect the change and requires a restart to pick up the new docker volume configurations.

I have a test server. I’ll give it a try. But, how do I do that?
Would I download the zip file from the main github?

I am testing from an update, I do not see the link for weight-height graphs in 2-year-old children (Growth-Chart). The same thing happens to me as in openemr demo (

hi @luisuriarte , you access it from the editing of the specific vitals now.

1 Like

The patient requested an appointment from the portal. Where is that appointment confirmed (or not)?


It is clarified that the user has permission to the portal

After updating, I find an error managing the translations. With 7.0.0(2) it worked fine.
(Latin American Spanish Language)

In demo
Same error.

where is this happening?
Chances are it’s not in translations but a previous error in sql that is trying to translate message.

In demo when I edit definitions or when I add constants

Oh okay. I’ve seen something similar during module development and was caused by table locking.
Brady will prob need to check this one out.

In the demo in English(Standard) some error.