Read about OpenEMR's Response to the COVID-19 Pandemic at

POS problem

For some reason our POS setting is defaulting to Pharmacy.

It is set in our facility settings to Office.

Any idea why this is happening and how we can fix it.

Jeff Guillory
Lumberton Tx
NP Health Clinic

If you are using 5.0.x, look at your encounter page. The POS can be set there if it is turned on. This will override what is in the facility settings.

We assume that POS codes which is displayed under encounter page is from the file “library/classes/POSRef.class.php”. For a New Encounter, the options for POS will display in the order that POS Code array had in the file. This is why, it displays Pharmacy as default because it is an initial value in that array. Its looks like there is no change in POS Code Dropdown based on facility settings.



You say, “if it is turned on.” Where do I turn this off, so that it will get the POS from the facility settings instead of the initial value in the POSRef.class.php array?


Why would there be no change in POS Code Dropdown based on facility settings? Isn’t it supposed to get that value from my facility settings?


@nursejeff The expected behavior of OpenEMR is there will be no change in the POS code drop down based on facility setting. If you want this feature, you may need to customize your code.

You can also refer the link which has a similar requirement. This is currently available in the development code base. Hope this might be of help to you.

ViSolve OpenEMR Customization Team

@nursejeff Turn it off under administration globals billing uncheck the box to set POS in encounter

Ok, thanks you guys.

I have turned it off in the admin as juggernautsei has explained above.

The choice to set POS in New Encounter is now gone.

POS is set in facility settings.

I will verify with my biller that we are no longer having this problem.

Thanks again.


@nursejeff - Once you verify the results could you please mark this as solved? Thank you

At our office, we need the POS on the encounter page so that when it is a telehealth encounter we can change POS from 11 (default office) to 2 (telehealth encounter); however, it would be really nice if it would default to the facility code (e.g., 11) instead of lowest value, which apparently happens to be pharmacy. Having to change it from pharmacy (1) to office (11) gets cumbersome after so many patients. Which file would be easiest to insert a command to check facility for a default value?

hmm, I did some work on POS, billing facility and more recently, 5.0.2 I believe. What version OpenEMR are you using?

5.0.2(1), just added eRx but problem is the same. On Windows Server with XAMPP 7.45.

I decided that because POS is only of interest to billing, I set the default POS from practices first billing location i.e facility. Does this help?

also, default POS is set in facilities.

okay - then something isn’t working. Under facilities, the POS for the first is set to “11:Office” and other values for a couple of other facilities, but none are pharmacies. Any ideas off-hand for where to look for why its not catching the 11?

Check what POS is set in your facility that is flagged as a billing facility. Set your default POS there…

Yes. We also have primary business entity checked, but no facility Id entered. I had my hopes up for a minute. I have had four openemr builds do this same thing, btw, all 5.0.2 to 5.0.2(1)

Okay, i’m missing something.
Summing up, you wish to have your default POS for new encounters set to 11(Office). Is this correct?

I would like it to default to my billing facility POS, which is 11.

It should! How many facilities are marked for billing locations?
Still, i’ll test again…

Nuts(or some expletives not appropriate here)! Something has broken since 5.0.2 release and patch 1… Billing location is no longer arbitrator for POS!

I’m looking closer into but we just released patch 2 so may have to give you an addendum to patch.
We’ll see…