Portal


(R Magauran) #1

Is the Portal feature for patient self registration going to be part of 5.0.1?
The code in the dev tip branch is giving some errors so I presume it is still in development?

eg. for Step 2 “Profile” I get:

The requested URL /openemr/portal/patient/patientdata was not found on this server.


(Jerry P) #2

Hi Ray,
Nope this was working. May fail if email notification is not set up but this error is a rest request and looks alright except i’d expect to see the domain. Try going to Administration->Globals->Portal->Portal Uses Server Base Path (internal) and toggle tick(default is unchecked). Also, is this on our demo? Or what is your setup.


(R Magauran) #3

I just tried it again with the Portal Uses Server Base Path (internal) unchecked.
It was checked. Same response at Step 2.
Interestingly, I can continue the process and enter an insurance.
Then at Step 4 “Send Request”, I get a javascript error:

'TypeError: document.getElementById(…).contentWindow.page is undefined register.php:143:13
https://example.com/openemr/portal/account/register.php:143:13
dispatch https://example.com/openemr/public/assets/jquery-min-3-1-1/index.js:3:10263
add/q.handle https://example.com/openemr/public/assets/jquery-min-3-1-1/index.js:3:8325`

This is my production server, Ubuntu 17.10, Apache 2.4, PHP 7.1.
Permissions for the /var/www/openemr/portal/patient/files = 644 www-data:www-data.


(R Magauran) #4

More info:

When I load the self-registration page, I get a 404 error for :

/openemr/portal/patient/patientdata?pid=0&register=true


(Jerry P) #5

This is valid uri but where is the domain. Is this from console error? Also, have you tried reinstall of portal directory with latest. Relative path’ing was an issue but was addressed few months ago. I’ve tested ubuntu 14.04, 16.04 and windows 10 but not 17. Also tested through php 7.1. Can you log into portal and access profile?


(Gerardo) #6

i have the same problem for patient self registration, do you can help me to resolve?! because I have the same problema like @rmagauran but I have installed server Amazon Linux server 2 AIM2
I send you a screen capture of problem from mi site thank you
|690x458


(Jerry P) #7

I’ve just retested and works okay for me. Have you installed 5.0.1 patches? Check here: https://www.open-emr.org/wiki/index.php/OpenEMR_Patches and be careful if you have custom code. The files for portal are what you need so just use them if you need to. Just let me know what patch version you are on now if any for others info.


(Gerardo) #8

hi @sjpadgett i follow your advices , I installed patch for 5.0.1 but the problem still there


i uploaded a small videos showing the problem
https://drive.google.com/file/d/16jAg_HEZcdotit-Md2sawTNIy-PMe0bu/view?usp=sharing

http://sendvid.com/rrv2ozro

(Jerry P) #9

Has to be something with your install. Check file permissions and user:group permissions in openemr/portal/patient directory if on ubuntu. Check browser console to see if the fetch returns a 404 or 500 error. Check php error logs for clues.


(Jerry P) #10

Ray if I remember correctly, you got this to work when you reinstalled. Is that correct?


(Gerardo) #11

I saw portal folder, the folder has permission 775 and ec2-user and apache group
but… the files inside the folder “Portal” has diferentes permission and groups, some files has permission 644 with ec2-user and apache group, and other files has permission 664 with ec2-user and groups ec2-user, is it correct ?
I’ll send you a screen capture


(Jerry P) #12

I assume this is Alpine in a docker container. No matter but i’m not sure what is in the apache group so suggest doing a recursive chown -R ec2-user:ec2-user on portal directory.
edit: are you able to log in as portal patient?


(R Magauran) #13

Still not working but I have not loaded the latest files.


(Jerry P) #14

Okay thanks. I don’t understand what is missing. All my testing works okay so i’ll try test some more.


(Stephen Waite) #15

hi Jerry, if I remember from another thread that the web server doesn’t like the leading /openemr in the path name?


(Jerry P) #16

That’s true but i’m pretty sure one of the patches adds a url test for making sure web_root is properly parsed for a relative endpoint. The browser should take care of the rest of inserting correct domain. @geromoss Really do need the browser console error to know for sure.


(Jerry P) #17

I just retested again against all our demos in demo farm including Alpine 3.7. All are okay. @geromoss Can you e-mail me your sites portal url so I can test myself? sjpadgett@gmail.com


(Gerardo) #18

i changed permission on Portal directory for ec2-user:ec2-user and still the same problem, i’m not using Alpine neither Docker container, just downloaded packed from oficial website OpenEMR version http://sourceforge.net/projects/openemr/files/OpenEMR%20Current/5.0.1.6/openemr-5.0.1.tar.gz
thank you @sjpadgett i send you an email with the link


(R Magauran) #19

I used a second browser to avoid session conflicts and it still failed. However I noticed in openemr, when I reset the browser credentials for my test user, the username in the pop-up was different than the username in the demographics for CMS Portal Login for this patient. When I changed this CMS Portal Login value to match the one autocreated (?), I was able to get it to work… Does that make sense?


(Jerry P) #20

I do know that only one portal should be enabled. I’ll check code but maybe i’m grabbing the wrong credentials. Anyway this is a clue, thanks. @geromoss Have you got more than one portal enabled in Globals?