@geromoss For some reason portal can’t access the patientdata restful endpoint. Must be something with server config. Maybe need to add server directory permissions for openemr/portal/patient directory or .htaccess is turn off. Are you behind a proxy, reverse proxy or load balancer that may be rewriting the url? Be sure to uncheck Portal Uses Server Base Path (internal) in Globals now that you did some changes and try. Once again, can you log in as a portal patient? Otherwise, I don’t know how to help.
@rmagauran Do you know if cms portal uses patient_access_onsite for passwords? If so then that’s an issue for running dual portals which by the way, the demo farm has all portals turned on so that may not be an issue.
Anyway, I can’t recreate so i’m at a loss.

All portals should be able to run simultaneously.
Left related comments on this thread:


1 Like

not working on demo server while in local system it is working fine
this above url is giving error 404
can anyone suggest please ?

i Solved it!
the problem is Amazon Ec2 has desactivated .htaccess for default and some file in folder openEmr have different permission and user group for default , so what i do was: change configuration in apache, delete complete folder OpenEMR, download again OpenEMER, unzip it and change permission and group recursive files and folders OpenEMR.
Details Instructions:

  1. go to configuration Apache (in my server Amazon Ec2 is located in /etc/httpd/conf/httpd.conf) sudo nano /etc/httpd/conf/httpd.conf
  2. go to DocumentRoot “/var/www/html” and looking for AllowOverride None
  3. changed AllowOverride None to AllowOverride All <- very important
  4. go to terminal /var/www/html and delete folder openEMR
  5. use wget http://www…tar.gz to download openEMR last version
  6. follow instruction to unzip OpenEMR zip in folder
  7. very importante change permission and group folder OpenEMR that correspond, in my case i use : sudo chown -R ec2-user:apache /var/www/html/openemr
  8. go to openEmr page setup.php and following instructions
  9. FIX IT!!! now patients have self-registration
    THANK TO EVERYDOY for your HELP , i think you should add text in install instructions page wiki use a command recursive like: sudo chown -R [user]:[group] /var/www/html/openemr because for some reason when unzip openEMR it has differents groups and permission default in some files PHP and CSS
    thank you

As per the screenshot, I have the patient portal under 443 SSL of third party wildcard certificate and getting this URL connection error for certain screens such as My Profile, My Messages and My Documents. Please see attached the relevant files
.htaccess (217 Bytes)
httpd.conf (21.3 KB)
httpd-ssl.conf (13.1 KB)
httpd-vhosts.conf (3.9 KB)
openemr.conf (1.0 KB)
. Read form posts and tried everything suggested and discussed on Sat call. Help greatly appreciated. Thanks!

For anyone getting 404 errors where the redirect is working, ensure you’re not using aliasing/redirecting directly into the portal directory from apache.

portal must be part of the URL e.g. https://domain/portal or https://domain/openemr/portal and not an alias of say DocumentRoot "C:/path/to/openemr/portal"

Portal is not a stand alone app but I do plan to allow portal to emulate as if a gateway in future.

1 Like