Portal v2 Registration never goes to step 2

portal

(Amir Eltaweel) #1

Hi

I’m using 5.01 on ubuntu, the v2 portal registration never goes to step 2. I get the following error

============================
The requested URL /mysite/portal/patient/patientdata was not found on this server.

Apache/2.4.18 (Ubuntu) Server at [www.mysite.com] Port 443

==================

any ideas guys


(Stephen Waite) #2

hi @amireltaweel, what are your settings under admin->globals->portal?


(Jerry P) #3

Ensure you are on latest patch or you may clone or download updates that are not in a patch yet where I have been back porting portal 5.0.2 changes to 5.0.1 here: GitHub - sjpadgett/openemr at portal-backport
Just copy openemr/portal directory on top of your production.
I haven’t seen this issue in a very long time and may have something to do with cross origin especially if you are behind proxy.
You may also try toggling this Global: Portal Uses Server Base Path (internal) in Administration->Globals->Portal tab.


(Amir Eltaweel) #4

I did toggle the Portal Uses Server Base Path (internal) back and forth and it made no difference. I’ll try the GitHub updates and feed back.

Thank you guys.


(Amir Eltaweel) #5

Guys, I did the new batch on a fresh install but nothing changed. still same Error.
it is looking for the “portal/patient/patientdat” folder which I don’t have.

I also noticed that the “portal dashboard” under misc is pointing to “portal/patient/provider” which also doesn’t exist.

I tried creating both folders manually, but still registration fails on step 2, continues to the following steps but fails to register the new patient at the end.


(Gerardo) #6

hi @amireltaweel i have the same error like you, did you resolved it? please help me


(Amir Eltaweel) #7

not yet brother :frowning: , will post if I got it to work


(Brady Miller) #8

Hi,

I think this error generally means the .htaccess stuff is not working:
openemr/.htaccess at master · openemr/openemr · GitHub

Which is usually either because:

  1. Apache has been set to ignore .htaccess
  2. Or you are using Alias in apache which then need to incorporate this instead into the apache site config like so: openemr/openemr.conf at master · openemr/openemr · GitHub

-brady


Portal
(Brady Miller) #9

Also, generally when the issue is an .htaccess issue, then the Module feature will also break in OpenEMR at Modules->Manage Modules


(Jerry P) #10

Thanks Brady, I’m going to have to test more with more than one portal enabled. Use to be an issue with Portal Dashboard if External was enabled but not seeing any longer so, maybe i’m good.
You are going to have to tell me your secret for having all these references at your finger tips. I can never seem to find them:)


(Jerry P) #11

Just for edification, patientdata and others are restful endpoints and refer to a controller via a predefined route and not directories.


(Amir Eltaweel) #12

Thank Brady,

The Modules > Manage Modules is working no problem while having this issue. I don’t know, but I’ll examine the couple of possibilities you mentioned and see. will feedback soon. Thanks again


(Amir Eltaweel) #13

Thank you JP for pointing that out :slight_smile:


(Gerardo) #14

i had the same problem like you and i can resolved it