Persistent Connectons


(Barrie C Fitz-Gerald, Ph.D.) #1

Unable to run OpenEMR shared environment. Can we run in normal mode without persistent con


(ViSolve) #2

Hi barringer7777,

We can able to run OpenEMR in shared environment . Can you please explain your issue with more detail?

Visolve


(Barrie C Fitz-Gerald, Ph.D.) #3

receiving the following error just prior to login: "Warning: mysqli_real_connect(): Persistent connections are disabled. Downgrading to normal in /home5/eteamusa/public_html/openemr/vendor/adodb/adodb-php/drivers/adodb-mysqli.inc.php on line 123


(Brady Miller) #4

Can you check your php.ini file for the value of allow_persistent?


(Barrie C Fitz-Gerald, Ph.D.) #5

extension=“mongo.so”
extension=“memcache.so”
;extension=“memcached.so”

apc.enabled=1
apc.enable_cli=1

short_open_tag=off
display_errors=off
display_startup_errors=off
error_reporting=E_ALL&~E_DEPRECATED&~E_STRICT&~E_NOTICE
register_globals=off
max_input_vars=3000
max_execution_time=60
max_input_time=90
post_max_size=30M
memory_limit=128M
allow_persistent=0
pconnect=FALSE

file_uploads=On


(Stephen Waite) #6

could try allow_persistent = on, and restart webserver


(Barrie C Fitz-Gerald, Ph.D.) #7

That’s the problem…we were attempting to run OpenEMR without persistent connections. Our Host is a “shared” environment and will not allow persistent connections to operate. Is it possible to run OpenEMR without persistent connections?


(Stephen Waite) #8

ok, don’t think it will be a prob but might cause slow performance, persistent connections php.net


(Barrie C Fitz-Gerald, Ph.D.) #9

Performance is not an issue…we just need to get access…using for student training. Saw your article, I thought we had it covered. Still not gaining access. Any further thoughts?


(Stephen Waite) #10

yes, display errors should be off so this warning would be fine in a log but will interrupt openemr

recommended php settings


(Barrie C Fitz-Gerald, Ph.D.) #11

And you’re suggesting what?


(Barrie C Fitz-Gerald, Ph.D.) #12

Sorry…just saw the file you recommended.

Will let you know.


(Barrie C Fitz-Gerald, Ph.D.) #13

It appears that the php.ini file is trying to affect the Server…which ignores “persistent connection” communications. What we need to do is change the OpenEMR application to prevent any request for “persistent connections”. Is there a file in OpenEMR that would affect this, either website or database?


(Barrie C Fitz-Gerald, Ph.D.) #14

Also…if necessary I can provide the phpinfo.php file with output.


(Stephen Waite) #15

hi @barringer7777, openemr runs without persistent connections, just confirmed on my test site, need to change webserver’s php.ini to not display errors


(Barrie C Fitz-Gerald, Ph.D.) #16

It’s not the display of errors…it’s that we are unable to get beyond the login page.


(Barrie C Fitz-Gerald, Ph.D.) #17

php.ini has display errors=off


(Stephen Waite) #18

hi @barringer7777, here’s a screenshot with display errors = on

can you confirm that you’re editing the correct php.ini and restarting the webserver? thanks


(Barrie C Fitz-Gerald, Ph.D.) #19

you can verify by checking the phpinfo.php file @ ehv-openemr.org/phpinfo.php


(Barrie C Fitz-Gerald, Ph.D.) #20

I’m editing the php.ini file in the root of the openemr directory