OpenEMR 5.0.2 install - Trying to Install ext. data, 2019 ICD10 Codes


(Paul) #1

Situation
In earlier editions of OpenEMR, the code set for ICD10 or 9, seemed to install pretty quickly. I have a test install on a small atom proc. based server with a ssd and 4 gigs of ram.

It seems like a quick experience and love the new editions look, though when trying to load the 2019 icd10 codes, it kinda stalls and nothing happens after like 20 minutes of letting the system try to do the install. After 20 minutes, I exit out of the ext data tab, and try again to go back to the ext data link. It shows the 2019 icd 10 box and that its not installed. Does this latest code set take a while to load? Or do I need to do something else.

Thank You, for all the hard work developers and doctors…I love that there is a choice to rival the other software offerings out there…and to me, the 2fa is a game changer in securing and keeping out unwanted visitors. I do have a yubikey. Have not tried to use it as it looks like im supposed to use a smartphone auth program that can recognize a bar code? It’d be awesome to see 2fa implemented like what aws does for accounts, such that a yubikey can be used to login to the accounts along with user and pass.

OpenEMR Version
5.0.2

Browser:
I’m using: Firefox

Operating System
I’m using: Latest Ubuntu Server

Logs
Did you check the logs? No, not yet.


(Stephen Waite) #2

(Paul) #3

Before installing Openemr, I changed the php.ini settings and turned on mysqli.allow_local_infile…….

I just looked at the link in your post and it read to also check MySQL, so I did that.

Lastly, I looked at the apache2 error.log file

That’s where Zip Archive could not be found. Must not have installed zip!

So, I downloaded both the dependency for zip and the php7.2-zip.deb file and installed both, restarted apache2…logged in to openemr and tried again to install icd10 2019 codes.

After about a minute…SUCCESS!

Thank You, for the reply.