I'm not able to open "Manage Modules" and "Portal Dashboard" on my OpenEMR Ubuntu instance

Situation
Hi everyone I have a little problem. I’m trying to open the Manage Modules and Portal Dashboard on my openemr installation on Ubuntu but it is not working. Instead I’m getting this error shown on the screenshot below.

What could be my problem? Kindly assist

OpenEMR Version
I’m using OpenEMR version 5.0.1

Browser:
I’m using Mozilla the latest version

Operating System
I’m using Ubuntu 20.04

Logs
Did you check the logs? Was there anything pertinent in them? Paste them here (surround with three backticks (```) for readability

Hi @Richard

Try the below configurations, on your apache conf file,

AllowOverride All
Require all granted

This may help you,.

Thanks,
ViSolve

Thank you @visolve for your reply. I have opened my apache2 config file by nano /etc/apache2/apache2.conf. However, I do not know where to make the changes you recommended. Kindly assist. Regards.

Hello @Richard

Try specifying it below <Directory /var/www/>

Let us know for further clarifications.

Regards,

ViSolve

@visolve I meant the lines of code you gave before I do not know what to do with them even after opening the apache config file. Could you kindly tell me whether I need to paste or there are specific lines I need to change.
Thank you in advance.

Hi @Richard,

Your apache config file should contain these lines.
If the lines are not there, just replace it as below.

Regards,
ViSolve

Hi @visolve changed the /var/www/ directory as you have advised and after restarting apache, I got a new error shown in the screenshot below.

Hi @Richard

Could you please try the following link.

Regards,
ViSolve

Thanks @visolve. I will give you feedback

@visolve could you please assist me on how I get to apache/httpd.conf to make the changes recommended?
Thank you inadvance.

Hi @Richard

For Ubuntu, you can add the below lines on /etc/apache2/apache2.conf file.

LoadModule rewrite_module modules/mod_rewrite.so
LoadModule headers_module modules/mod_headers.so

Another method is you can create a new httpd.conf file in apache2 directory.
Add the above mentioned lines in httpd.conf file.
Also in apache2.conf file add the below line

Include /etc/apache2/httpd.conf

This may help you.

Regards,
ViSolve

@visolve I have tried both methods, ie adding the lines directly to the conf file and creating htt.conf file. Unfortunately when I restart apache using sudo systemctl restart apache2 I get the error on the screenshot below and the apache server fails to work.
See the error below.

The next screenshot shows the point where I have entered the line Include /etc/apache2/httpd.conf

The last one shows how I have create httpd.conf file as advised

Hi @Richard

Try Specifying the below lines in the httpd.conf file.

LoadModule rewrite_module /usr/lib/apache2/modules/mod_rewrite.so
LoadModule headers_module /usr/lib/apache2/modules/mod_headers.so

Then restart your apache and this will solve your issue.

Regards,
ViSolve

I’m in the same boat.

I also experienced similar issues with an install of OpenEMR 6.0 on OpenSuse 15.3.

Here are the steps I did to install OpenEMR 6.0 on OpenSuse 15.3 (You can also adapt it to other distros).

  1. Install LAMPP stack on your distro. (Google is your friend). For reference you can use this howto https://www.osradar.com/install-lamp-opensuse-15-2-15-1/

  2. Download OpenEMR 6.0 https://sourceforge.net/projects/openemr/files/OpenEMR%20Current/6.0.0/openemr-6.0.0.tar.gz/download and extract to your apache2 www root directory /srv/www/htdocs/

  3. Use this as reference to install OpenEMR 6.0 on Ubuntu or other distros https://www.digitalocean.com/community/tutorials/how-to-install-openemr-on-ubuntu-20-04-2

  4. Use MariaDB instead of MySQL, using #3 step above, create the OpenEMR database and user (make sure you write down username and password, you’ll need it later to complete the install)
    NOTE: Some directory paths on Ubuntu and other distros will be different (Google is your friend).

I edited apache2 config file by using the step below to resolve the Error 500 and 403 when trying to access Manage Modules

  1. sudo nano /etc/apache2/httpd.conf make the changes in the section like this:
    <Directory /srv/www/htdocs/> or <Directory /var/www/html> for Ubuntu and other distros
    Options FollowSymLinks
    AllowOverride All
    Require all granted
    <ifModule !mod_access_compat.c>
    Options FollowSymLinks
    AllowOverride All
    Require all granted


    Options FollowSymLinks
    AllowOverride All
    Require all granted

I haven’t tried installing it yet on Ubuntu but I also got it working using same steps on my laptop which runs Linux Mint 20.

Good luck!

I am assuming you have overcome this problem? yes?

This is what worked for me when I installed release 6.1 on Ubuntu:

Fix Issue with Portal Dashboard not opening

Commands:

sudo a2enmod headers

sudo a2enmod rewrite

sudo systemctl restart apache2

Open the Miscellaneous || Portal Dashboard menu.

Click on the manage templates button to see if the next screen will open. If it does, this step is complete.

2 Likes