ICD10 Install Problem OEMR7

I’m trying to install ICD10 codes in open ERM7. When I click the install button i get a little wheel that spins and spins and nothing else happens until the software signs me out after a while. when I sign back in the codes are not installed and I have to start the process over again with the same results.

Open EMR 7(Fresh Install, not an upgrade), Firefox, Ubuntu Linux 22.04, PHP 8.1.

Error from error log:
PHP Fatal error: Uncaught Error: Class “ZipArchive” not found in /var/www/html/openemr/library/standard_tables_capture.inc:53\nStack trace:\n#0 /var/www/html/openemr/library/standard_tables_capture.inc(797): temp_unarchive()\n#1 /var/www/html/openemr/interface/code_systems/standard_tables_manage.php(52): handle_zip_file()\n#2 {main}\n thrown in /var/www/html/openemr/library/standard_tables_capture.inc on line 53, referer:

Make sure that you have the ‘php-zip’ , 'php8.1-zip and ‘php-pclzip’ packages installed in your operating system. Then reload your web server and try the code installation again.

1 Like

That did the trick. Many thanks.

I did and this did not solve the issue for me. Thanks for the suggestion.

That did the trick here too. Many thanks as well!

I’m on Windows 10. The only extension of the above 3 that came with the latest version of XAMPP was php-zip. I did have to copy and paste the php-zip.dll file from XAMPP to windows\system32 after removing the “;” in php.ini, but then it worked perfectly after that.

Thank you again!

1 Like

While trying to install ICD10 from admin, external codes, I get this error.

Successfully Upgraded ICD10
Fatal error: Uncaught Error: Class “ZipArchive” not found in
C:\xampp\htcdoc\openemr\library\standard_tables_capture.inc.php:53 Stack trace: #0
temp_unarchive(‘C:\Users\DREXOD…’, ‘ICD10’) #1
C:\xampp\htcdoc\openemr\interface\code_systems\standard_tables_manage.php(52): handle_zip_file(‘ICD10’,‘C:/xampp/htdoca…’) #2 {main} throw in
C:\xampp\htcdoc\openemr\library\standard_tables_capture.inc.php on line 53

Please help thanks
OS: Windows 10
Open emr v7.0.1
Php version 8.2

Ive done all suggestions but still not working.
The last suggestion caused it to loop without error message when I click install but it loops forever.

Hi Samson Exoduzexsammy
Welcome to openemr community. :handshake:
Make sure your php operation system have php-zip.dll packages.


Please where do I find the file?

Sorry am not a tech savy