ICD10s not showing to be installed on new installation

I have a brand new installation of OpenEMR 7.0.0(2). I downloaded the code from the installation page. No modes have been done.

When I went to External data loads. This is what I see.
Any ideas why?

Even if I remove the files from the folder. The message stays the same.


I am assuming you run sql_patch.php after copying the patch files. After this step,

Delete the 2022 versions of the zip files in the icd10 directory

2022-Code Descriptions.zip
Zip file 3 2022 ICD-10-PCS Codes File.zip.

Refresh the tab after deletion. The upgrade/install button should appear.

Hope this helps

1 Like

@juggernautsei i had a similar problem on a fresh server with a fresh install of oemr7. My issue was that the php modules for zip files weren’t installed.
See this post:

your assumption is incorrect. Since the newly downloaded code comes with the patch. There is no need to download the patch separately. So, there was no reason in my mind to run the sql_patch.php file.
I ran the sql_patch.php file as suggested by your comments. Then I removed the recommended files. That worked.

1 Like