ePrescribing Solution Weno


(Sherwin Gaddis) #21

@QUC

Application for service:

Those that would like to use the eRx service please download this application

This information is also on the page below. Email in the requested information and it should take two days to get your credentials.

https://open-emr.org/wiki/index.php/OpenEMR_ePrescribe#Weno


(Quality Urgent Care) #22

@juggernautsei
That was where I got stuck and ended up contacting Tina Goodman. The linked application form says ‘scan and email to IDP representative’ but doesn’t mention an email or any other contact info. The open-emr.org wiki page linked there points to an openmedpractice.com page which says this, “The requested page “/os/eRx-Sign-Up” could not be found.” I tried blundering around their website but the only thing I found for signups is this: http://www.openmedpractice.com/os/Sign-Up
, which is posted by ‘Sherwin’ dated 2015 and just says “sign up”, but doesn’t mention weno anywhere.
So, where does the application go? Where is the proper signup link?


(Sherwin Gaddis) #23

There seems to be some inconsistency in my documentation.

I shall correct that momentary. In the mean time send the documentation and application to sherwin @ openmedpractice . com

I have updated the document and updated the website http://www.openmedpractice.com/os/Sign-Up. It now says Weno OpenEMR eRx.

Thanks for your diligence and patience.


(Sherwin Gaddis) #24

@QUC

The weno system no longer requires a prescribers ID or Clinic ID. So, I need someone to test the system.

Here is all the information you need for any prescriber.

        Weno eRx Account ID : 137
  Weno eRx Account password : 7C84773D5063B20BC9E41636A091C6F17E9C1E34 

Enter this information in the Globals -> Connector -> Weno eRx Account ID.

Have the doctors prescribe the medication. It should go through to the pharmacy.

Let me know if it does or does not.

Also, in the Weno Admin don’t import Pharmacies. It is no longer needed as well.


(Quality Urgent Care) #25

Thanks very much, @juggernautsei! I’ll get my doctor to try it asap, when she’s not too busy to help.


(Quality Urgent Care) #26

@juggernautsei

Trying to go a bit further, since I can’t get my doctor’s help for now, it looks like there is a problem if there’s no clinic ID. I went to transmit, and got this:

“Weno Account Clinic ID information missing”

Should I put in some dummy number for clinic ID? Do I need to set pharmacy info somewhere before I do this?


(Sherwin Gaddis) #27

We are doing some testing and I will get back to you tomorrow.


(John Macken) #28

changed the name of the topic for future users!


(Sherwin Gaddis) #29

Thanks @mackenj

@QUC
did you get the doc to help you?

The information on this page

https://open-emr.org/wiki/index.php/OpenEMR_ePrescribe#Activate_Service

has been updated. Please review.


(Quality Urgent Care) #30

Hi @juggernautsei ,
We are trying it this morning, followed the updated directions on your page, put in the clinic ID and checked simplified prescriptions, update the weno management for our town and a nearby one. It looks like when you import pharmacies, a lot of the ones in the selected local area are not in the list and need to be added manually in the administration->practice->pharmacies page, is that right? On the pharmacy setup page, there are npi and ncpdp numbers for the pharmacy, the doctor wants to know whose NPI goes there? So, we tried a transmit and it is taking a couple minutes so far, how long should it take? She said with practice fusion it was done in a second. Maybe we’re still not set up right.


(Sherwin Gaddis) #31

The transmission should take 10 seconds.

If it not going through it is because there is missing information.

The NPI can be gotten from the

https://npiregistry.cms.hhs.gov/registry/provider-search

The NCPdp ID is not as easy to find. You may have to call the pharmacy to get that number. I placed a call to the www.ncpdp.org and waiting a return call as it is the weekend now and they are closed.

But time and time again, I do share that if any information that is required is missing, the script will not go through. It does not accept close enough.

All the patient information must be entered and a pharmacy assigned to the patient in the chart.
The zip code of the practice can only be 5 digits. Remove the extra 4 digits if you have that in your system.

The pharmacies are not an all inclusive list and I would really recommend manually entering in the pharmacies that are local to you and the ones that you use. There is no reason to have more than that in the system.
(just my opinion)


(Quality Urgent Care) #32

Thanks @juggernautsei, a quick follow-up: There’s a ‘default method’ field in the pharmacy settings page, with choices of print, email and fax. This is how the pharmacy receives the rx, correct? If it’s fax, how does the fax go out, through weno? I haven’t setup a fax in our EMR yet, not even sure how yet.


(Sherwin Gaddis) #33

If you do not see the transmit button that means that you have not enable the weno service.
Go to Administration and then go to connectors and scroll down and check the box to enable the program.


(Quality Urgent Care) #34

Transmit button is there and we can push it. I guess my question is what’s going on under the hood when we transmit. The pharmacy info has a fax, email, and default method of fax, email and print. Just wondering if those fields are used by the weno system, where does the fax originate from, etc.


(Quality Urgent Care) #35

@juggernautsei here is our current status. There’s a pic of the transmit window, it just cycles indefinitely. That pharmacy in that pt record has all of the numbers entered and default mode fax. Is there a log or something we could look at that would tell us why it’s stuck?


(Sherwin Gaddis) #36

To find out what the error is, right click on the screen and go down to select inspect. In the next window, click on console. It will show you what is the error.

I can tell you it is a JavaScript error.


(Quality Urgent Care) #37

@juggernautsei, We got it working, once. Tried your instruction of looking at the browser console. I saw two suspiscous looking things in the post header: 1 - Our facility fax number was 0000000000. 2 - The weno clinc ID had three sets of numbers separated by colons, the C36275 from the wiki link, plus two more probably from outdated instructions we tried before.

We fixed the fax number in facility settings, found the two extra weno IDs coming from the doc’s user settings weno ID, deleted those, tried again and it worked.

However, we then tried another script and got bounced immediately. I found that the unwanted weno IDs in the user settings kept replacing themselves every time I deleted them from the user settings then subsequently saved them. Fixed that by going to phpadmin and deleted them from the doc’s user record.

Tried again, selected previously entered script that failed last time, saw that the ‘send new rx’ checkbox was unavailable for the previously failed meds. Tried the ‘refill rx’, transmitted that and got a fail in the console network tab within 300ms. It said, “(failed) net::ERR_CERT_DATE_INVALID”. The transmit box stays up and doesn’t report any result.

I don’t know why it worked once but not again after that. Any ideas what we should check? Thanks for your help.


(Sherwin Gaddis) #38

Try flushing out the browser by closing the browser and reopening it.
If you are repeatedly trying to send a prescription, the json code will accumulate in the browser cache.

From our log files, the entire message is not arriving to the server. I don’t know why. I can’t see your machine.

One of the things that you can check in your browser before you click the transmit button is to make sure that the system is creating a fulling formed message.

In the browser you should see the prescriptions packaged like below.

 [{"patient":{"lname":"Simpson","fname":"Jessica","street":"99 Market St","city":"Portsmouth","postal":"23704","DOB":"1971-07-07","Sex":"F"}},{"provider": {"provlname":"Mark","provfname":"East","provnpi":"123456789","facilityfax":"7574986987","facilityphone":"7578188498","facilityname":"Johnny Nine Toes","facilitystreet":"145 Jack Hammer Ln","facilitycity":"Sparta","facilitystate":"VA","facilityzip":"23526","qualifier":"D91539:C29729","wenoAccountId":"111","wenoAccountPass":"A80B97AB1A80B92084CB86DE61A1F82A6979990B","wenoClinicId":"D91539:C29729"}},{"pharmacy":{"storename":"WALGREENS #891","storenpi":"4000131","pharmacy":"1255347696","pharmacyPhone":"7877671143","pharmacyFax":""}},{"script":{"drugName":"NORVASC      TAB 10MG","drug_NDC":"0","dateAdded":"2017-05-26","quantity":"20","refills":null,"dateModified":"2017-05-26","note":"wewewe","take":"wewew"}}]

The qualifier field does not matter.
Let me know if you are not getting a fully formed message for each drug that is being transmitted.


(Quality Urgent Care) #39

Tried firefox instead of chrome. Still fails but what I see in the console (not familiar with FF) is different. Can’t find the post header content like in chrome, need to educate myself. But the error is more verbose, is this a showstopper?

apa.openmedpractice.com uses an invalid security certificate. The certificate expired on Friday, May 18, 2018, 4:33 PM. The current time is Monday, May 21, 2018, 11:22 AM. Error code: SEC_ERROR_EXPIRED_CERTIFICATE


(Asher Densmore-Lynn) #40

Ow, that’s a something, yeah.