Database for Testing Purposes (?)


(Maricel Medina-Mora) #1

Hi,

I am new to openEMR. I am an instructional designer and want to populate the EMR with fake data. Is there any database that has been created that we can get data from?


(ViSolve) #2

Hi @mmedian,

You can use slick data generator for random patient_data,insurance data. It can be download from the link here.

After creating the demo sql file,you need to import the particular sql file into you database.

For example :

mysql -u root -p openemr_database < demopatients.sql

You can also use default sample patient_data table available in the OpenEMR’s sql directory.

Let us know for further questions.

Thanks,
ViSolve


(Brady Miller) #3

Hi @mmedina ,

Couple things.

How much data are you looking for?(we have some basic demo data that is used in the demos and we are currently working on supporting bringing in large amounts of demo data along with support for heavy data analysis): Can see several related project on the project roadmap here: http://www.open-emr.org/wiki/index.php/Roadmaps

We are also currently working on providing support for EDU (education, classrooms, instructional, research) use and can see more on this here: OpenEMR EDU

-brady


(Maricel Medina-Mora) #4

Thanks so much for your great support and quick answer. I would like to get enough data so we can create case-based scenarios for different classes. After each quarter, we should be able to reset the database and start over or add new data.

However, I have a bigger problem. We installed the application in AWS and I am trying to figure out how to have access directly to the database. I want to be able to import data automatically using mysql or phpmyadmin.

Once I know that, it will be easier to import the data. I know this is open source and perhaps we don’t get personalized support. If someone can guide me trying to find the way to get into the database, it will be great.


(Asher Densmore-Lynn) #5

Hiya, @mmedina. Did you use one of our custom AWS deployments? If you can tell me which one, I can tell you how to get access.


(Maricel Medina-Mora) #6

Hi,

My colleague installed it using AWS OpenEMR Cloud Full Stack (openemr-devops/packages/full_stack at master · openemr/openemr-devops · GitHub). Now, I am not an expert in AWS but I am following the guideline and trying to get to the database using the steps listed under VPN access (openemr-devops/04-VPN-Access.md at master · openemr/openemr-devops · GitHub). However, I encountered a deadlock on step on Step 8 under Configure VPN Server.

Now, the only thing I want to do is to access the SQL database so I can import any data directly on the tables. Any suggestions?

I think it will be easier to talk on the phone if someone could help me so I can share my screen.


(Asher Densmore-Lynn) #7

Hello, mmedina.

It sounds like you’re not in the security group of the OpenVPN instance – make sure that the VPN is in an EC2 security group that allows access from your location on port 22. Add a security group if necessary to arrange this.

(You may need to add access to 443 and 943 as well – something tells me they may be blocked too.)

You have to use VPN to access the database because the SQL server is locked behind the VPC – no connections are possible from outside that network.

I hope this helps! You might consider consulting your colleague for further support, since they seem handy enough with AWS to be able to operate CloudFormation.


(Maricel Medina-Mora) #8

Well, both are new to AWS… We get totally lost on this system… We have tried many times but when we get to Step 5 of Establish a VPN Server for Private Cloud Access we don’t see the value openemr-vpc. on the listbox for Network.


(Asher Densmore-Lynn) #9

Can you tell me more about the “listbox”? Where are you seeing it, and what options do you have?


(Maricel Medina-Mora) #10

See attached file, step 5 says: For Network, select openemr-vpc. but we don’t see that on the list. We have followed the steps all over and over and still are not able to reproduce the steps.


(Asher Densmore-Lynn) #11

Oh my word, you’re entirely correct. That snuck in from an old version of the guide.

Alright, here’s what you need to do – start the stack, complete the stack, and then check the Resources tab for ‘VPC’ and use that VPC.

I apologize for the trouble, and I’m patching this for the next stack version right now.


(Maricel Medina-Mora) #12

I am sorry, but I think I am a little lost… Do you mean on AWS? Where do I find the resources tab? VPC?


(Asher Densmore-Lynn) #13

Do you remember running the stack in CloudFormation? It said CREATE_IN_PROGRESS for a while, and there were several tabs in the middle of the screen that discussed “Output” and “Events” and “Resources”?

Return to CloudFormation and select ‘Resources’, and scroll down for where it talks about the VPC created for the stack. THAT’s the VPC you assign the VPN instance to, at the spot where you’re stuck – earlier versions of this guide created the network through a different technique that allowed it to be named.


(Maricel Medina-Mora) #14

Nothing has worked yet. I am looking for a person/company who can spend 3-5 hours with us remotely and we can get this done. We don’t need anything else, just access to the database so we can create our own using the testing sample. And yes, we know about database integrity issues.


(Maricel Medina-Mora) #15

I am happy to report that after months of not having anything done, we will have access to the database and was able to import patients in an automated way. We are making progress one step at the time.