Read about OpenEMR's Response to the COVID-19 Pandemic at https://www.open-emr.org/covid19/

XAMPP version for EMR - 5.0.2. Windows 10

Need a help to reinstall EMR-5.0.2 for Windows 10.
Which the XAMPP version is supported. Installed the latest one and got a lot of errors.

This is a good reminder for me to try to get the Xampp-openemr 5.0.2 package out (had some bugs when doing this several months ago and then got distracted) since lots of the reported install issues are from trying to install openemr on windows/xampp.

1 Like

Hi Brady!
Please let me know if Xampp-openemr 5.0.2 package will be available soon.
I tried very hard to move to Linux, but I cant resolve the problems with Open EMR installation process.

Could you please post the issues you faced during the installation?
-ViSolve-001

Hi @ncavalier ,
It’s high priority on my TODO list. While waiting, try this:

  1. Reinstall Linux mint
  2. Install docker and docker-composer: https://computingforgeeks.com/install-docker-and-docker-compose-on-linux-mint-19/
  3. Then run following commands:
mkdir testopenemr
cd testopenemr
wget https://gist.githubusercontent.com/bradymiller/8f8dc5215b07d287f7dc0fed80bf2b9d/raw/9b2a762849bbf8ce0a0d4dff30c4a359cfa88a44/openemr-502-docker-example-docker-compose.yml
mv openemr-502-docker-example-docker-compose.yml docker-compose.yml
docker-compose up -d

Then wait 10 minutes
then go to http://localhost
(you should see the login screen)
(note the cool thing here with docker is that all you install on Linux Mint is Docker and don’t need to worry about dependencies etc.)

If you get it working, let me know, then I’ll walk you through how it worked and where it all is.

-brady

1 Like

I already posted the issues on my other post

Hi Brady,
Did everything step by step, installed fresh Linux Mint, Installed docker and docker-composer, then testopenemr.

Saving to: ‘openemr-502-docker-example-docker-compose.yml’

openemr-502-docker- 100%[===================>] 1.07K --.-KB/s in 0s

2020-02-19 19:02:36 (17.5 MB/s) - ‘openemr-502-docker-example-docker-compose.yml’ saved [1099/1099]

nerik@nerik-OptiPlex-380:~/testopenemr$ mv openemr-502-docker-example-docker-compose.yml docker-compose.yml
nerik@nerik-OptiPlex-380:~/testopenemr$ docker-compose up -d
/usr/bin/docker-compose: line 1: Not: command not found
nerik@nerik-OptiPlex-380:~/testopenemr$

After 10 minutes tried to open http://localhost - not working

I have another question. When we finely will finish this installation on Docker, can we restore our backup data from OpenEMR 5.0.1.(7) windows version, or we need to downgrade Docker to 5.0.1.
Please let me know if we need start from OpenEMR 5.0.1.(7)

This section says docker did not run.

What is the output if you enter

docker system info

Until you get docker container running, you would not get browser response. When openemr docker runs first time, you should monitor the logs to check the progress

docker logs name-of-emr-container

The script will start web server at the end after performing necessary setup. This will be seen as the last line of the log.

Output for - docker system info

nerik@nerik-2060:~$ docker system info
Containers: 0
Running: 0
Paused: 0
Stopped: 0
Images: 0
Server Version: 18.09.7
Storage Driver: overlay2
Backing Filesystem: extfs
Supports d_type: true
Native Overlay Diff: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local
Network: bridge host macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version:
runc version: N/A
init version: v0.18.0 (expected: fec3683b971d9c3ef73f284f176672c44b448662)
Security Options:
apparmor
seccomp
Profile: default
Kernel Version: 5.0.0-32-generic
Operating System: Linux Mint 19.3
OSType: linux
Architecture: i686
CPUs: 2
Total Memory: 2.848GiB
Name: nerik-2060
ID: MSL6:EZG4:LGTV:XRPW:NEVI:KUFG:WI27:OSBW:3D4H:WB67:PFQD:DZZA
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Labels:
Experimental: false
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false

I reinstalled Linux Mint 19.3. and tried everything again. I got a file docker compose, test emr, bur still not opening

hi @ncavalier, no need to reinstall mint, could you paste the output of the below again:

nerik@nerik-OptiPlex-380:~/testopenemr$ docker-compose up -d

the below doesn’t seem right

/usr/bin/docker-compose: line 1: Not: command not found

you could try reinstalling docker-compose with

sudo apt-get -y  install docker-compose

nerik@nerik-2060:~$ sudo apt-get -y install docker-compose
[sudo] password for nerik:
Reading package lists… Done
Building dependency tree
Reading state information… Done
docker-compose is already the newest version (1.17.1-2).
0 upgraded, 0 newly installed, 0 to remove and 242 not upgraded.

Same, no any changes

ok, thanks and
ls -lrt docker-compose.yml
?

and
docker-compose -v

Is there is any tutorials how to install and run Open Emr on Linux Mint platform.
Link provided by Bredy is not working correctly. Found some recommendations online for Linux Mint 19.3, and also can’t make proper installation.
There’s also no any instructions for Linux Mint on docker site.
Maybe it’s not the best time now to move from windows to docker…

this is the best tutorial :wink:
it’s something simple and we’ll get you up and running quickly

does this command spit out a version? if so then it’s something with your docker-compose.yml file

nerik@nerik-2060:~$ docker-compose -v
/usr/bin/docker-compose: line 1: Not: command not found

what about the command
which docker-compose
mine says

steve@penguin:~/Downloads$ which docker-compose
/usr/bin/docker-compose

nerik@nerik-2060:~$ ls -lrt docker-compose.yml
ls: cannot access ‘docker-compose.yml’: No such file or directory

ok, get into your docker directory
cd testopenemr