X12 failing after 7.0.1 upgrade

can no longer generate x12 after upgrading to v7.0.1. when attempting generate only a white screen loads in the pop-up box that used to have x12.

OpenEMR Version
I’m using OpenEMR version

I’m using: firefox

Operating System
I’m using: osx

Did you search the forum for similar questions? yes

Did you check the logs? error seems to point to file https://domain.com/interface/billing/billing_report.php

Was there anything pertinent in them?
Please paste them here (surround with three backticks (```) for readability.
You can also turn on User Debugging under Administration->Globals->Logging User Debugging Options=>All

I had something similar happen when setting up a client to send me claims the other day. For them we checked the box in Configuration->Billing->Generate X-12 Based on Insurance Company

I’m able to duplicate what you describe in the demo servers. with that option un-checked just a white screen is presented. Once I check the option and save it, more information is given.

I have a module “ClaimRev Clearinghouse Connector” it has a simple query of the table EDI files are stored in. I’m not sure if there is a similar report in the system, but it’ll give you some insight on if a file is created and what happened with it.


Hi Brad! Wow, you’re a rock star, that was it. It is working now. We really appreciate you responding back so fast and especially on the weekend. Thanks so much, take care.

1 Like

hi guys, if you’d like to not use that global, after you upgrade to patch 1 please see this thread

1 Like

Hi Stephen,
Thanks for the info, we are going to try this. Though we could see the data, we were unable to create the x12.

Hi Stephen,

We added the new files you referenced but still get the following when trying to generate the x12.

Do you have any additional thoughts as to why this is still out?

Billing queue results:

No directory for X12 partner Office Ally

You’ll want to turn off the global in config if you’re not going to bill directly to insurance companies.

Yep, that’s it. Thanks @stephenwaite