Upgrading from 5.0.0(7) to 5.0.1 Failed


(Shabbir Ali) #1

I was trying to upgrade 5.0.0(7) to 5.0.1 following the instructions from the link below:
https://www.open-emr.org/wiki/index.php/Ubuntu_Package_Upgrade_to_5.0.1_with_PHP5

I have Ubuntu 14.04.5. First time upgrade failed almost at the end and I got the below message when I go to my openemr, I got this message:

PHP version needs to be at least 5.6.0

When I tried to upgrade again, seems like the upgrade was successful but I am still getting the above message. I am hitting a wall with this. I appreciate if anyone can help me with this.


(Brady Miller) #2

Hi @smirzaoe ,

The issue is that OpenEMR 5.0.1 is not compatible with any PHP versions below 5.6.0 . This likely means you’ll need to migrate to a more modern Ubuntu version.

-brady


(Jerry P) #3

@smirzaoe PHP 5.6.4 works well with Ubuntu 14.04 if you would just like to upgrade the PHP version.


(Shabbir Ali) #4

Thanks Brady and Jerry. I appreciate your replies.

Last night we upgraded Ubuntu to the latest version. We choose the default options while upgrading. After the upgrade we found out that there is no openemr database in Mysql. It is showing only two default databases. I don’t know if there is a way to recover my databases. This is my test server.


(harley) #5

Hi Folks-
I’m trying to install OpenEMR 5.0.1, and got the ‘must be at least 5.6.0’ message. I did have 5.5-something so upgraded. Now I do this and see:
$ php -v
PHP 5.6.36-1+ubuntu14.04.1+deb.sury.org+1 (cli)

and still with the ‘must be at least 5.6.0’ error.
Do I need to uninstall the previous version of php or something for OpenEMR to use the 5.6.36?

I’m on a Linux Mint 17.2 box, if that’s relevant. And just for grins I do keep an older (4.2) version of OpenEMR installed also. And am using the tar file version rather than the .deb installer.


(Brady Miller) #6

Hi @htuck ,
It looks like this is the cli (command line) php version. A nice trick to figure out what PHP version is being used (use that older 4.2 version of OpenEMR on the same box) is at Administration->Other->Calendar->Test System
(you’ll see the PHP Version listed there).
-brady


(harley) #7

Thanks, Brady- I ended up taling a different route, which developed problems I’ll describe in a different post.
Rgds- HT


(Tyran Mincey) #8

I just upgraded EMR from 4.2.1 to 5.0.0 and from php 5.59 to php 5.6 I have confirmed on the serves that php 5.6 was successfull and the emr installation was successful and installed but when I try to login and type ipaddress as is usually successful I get the the following message - “PHP version needs to be at least 5.6.0.” I am unsure what else I can do?

Please advise
Thanks
Tyran


(Tyran Mincey) #9

I actually used the a2dismod php5 and a2enmode php5.6 commands to get the site to work. No that it works I get the erro r listed below

Query Error

ERROR: insert failed: insert into log ( date, event,category, user, groupname, success, comments, crt_user, patient_id) values ( NOW(), ‘login’,‘login’,‘tyran’,‘Default’,‘1’,‘success: 192.168.1.125’,NULL,NULL)

Error: Unknown column ‘category’ in ‘field list’

/var/www/openemr/library/log.inc at 45:sqlInsertClean_audit
/var/www/openemr/library/authentication/login_operations.php at 113:newEvent(login,tyran,Default,1,success: 192.168.1.125)
/var/www/openemr/library/auth.inc at 47:validate_user_password(tyran,Default)
/var/www/openemr/interface/globals.php at 574:include_once(/var/www/openemr/library/auth.inc)
/var/www/openemr/interface/main/main_screen.php at 25:require_once(/var/www/openemr/interface/globals.php)


(Jerry P) #10

Try running sql_upgrade.php again.