Upgrade from v6.0.0(3) to v7.0.0

I did successful upgrade from v6.0.0(3) to v7.0.0 and just discovered one problem with modules tab.

Please let me know how to resolve this issue.

check out this helpful thread

Thank you @stephenwaite for your support

I just did recommended configuration, but no any changes, still same error

/var/www/html/openemr$ sudo a2enmod rewrite
[sudo] password for nerik:
Enabling module rewrite.
To activate the new configuration, you need to run:
systemctl restart apache2

“sudo systemctl reload apache2”

Hi @stephenwaite ,

I tried two recommendations

/var/www/html/openemr$ sudo a2enmod rewrite
[sudo] password for nerik:
Enabling module rewrite.
To activate the new configuration, you need to run:
systemctl restart apache2

“sudo systemctl reload apache2”

and the second

/var/www/html/openemr$ AllowOverride FileInfo Options=All
AllowOverride: command not found

First command didn’t resolve the problem, and the second command not found

This is not a command, you usually add this to your Apache web server .conf file. The file is usually found in /etc/apache2/sites-available. I think it also goes within the <directory> </directory> section.

Check this link for [sample configuration](How to configure Apache 2.

Also it helps to look into apache log files in /var/log/apache2 for any error messages.

Hope this helps.

1 Like

@stephenwaite @brady.miller

Another issue found on v7.0.0. - Vitals fields not configured correctly, and only can’t be used for one digit number. Vitals information’s is not saving.

V7.0.0. vitals screenshot

v6.0.0 vital screenshot

If you can see in attached pictures, two additional added tabs in Vitals v7.0.0., “Abn” & “Actions” effected to the size of data entry tab, and the tab became not functional.

All together after upgrade from v6.0.0. to V.7.0.0 we experiencing 3 problems

  1. Modules
  2. Facilities Upgrade from v6.0.0(3) to v7.0.0 - Inactive Facilities select issue

Because of all this problems, we decided today to temporally convert back to 6.0.0.(4), because v7.0.0. not practically functional for our practice now.

There is also, attached Menu screenshots, where you can see, in V7.0.0 menu shrink to left side, and looks mach better in privies versions.



for the vitals, can you try clearing the browser’s cache and the openemr smarty cache at Admin->Clinic->Calendar?

I just did Admin->Clinic->Calendar - no any changes.

I just checked Vital on v.7.0.0 demo, same problem. In first encounter data entry field looks good, but after adding more encounters, its shrinking to smaller size, and after 7 encounters we can only enter 1 digit number. And you can see on demo also, vital not recording entered data and not providing any calculations. It’s completely not functional.

V7.0.0 Demo - Vital with 1 encounter

V7.0.0 Demo - Vital with 7 encounters

1 Like

@brady.miller @stephenwaite
I’m just checking if there is a way to resolve the main problem with the Vitals. I posted information regarding issue with Vitals, and didn’t received any updates. Problem not only in my installation. Demo v7.0.0. have the same problem. I checked on 5 different computers, and all the same. We just converted back to v6.0.0(4), because we need to continue use our system.

hi @ncavalier , the fix for saving vitals was just added to 700 this morning, for the display issue we’re in discussion about how to best proceed and @adunsulag has an idea

Thank You @stephenwaite for replay.
Do we need to download updated 7.0.0 file for installation.

probably easier to wait for the 1st patch

What about modules tab, I still cant resolve this problem

I don’t have openemr.conf in apache2 directory

getting good advice @ Modules > Manage Modules = 500 error - #18 by BenCan

Here is the github issue with screenshots of the vitals form fixes I’m proposing:

I wonder if this is related to re-write rules in apache?

Hello everyone,
I trust we’re all good.

I have an issue with my 6.0.0 instance.

The procedure order and result configuration page stopped loading and is blank.

I have inspected the network log for the type_ajax call with successfully returns data. However, the data isn’t rendered.

See attached screenshot for context

Attached also is the preview of the result from the network tab of my inspector

I need help with this @brady.miller @sjpadgett @LMoonsammy @hitechelp