Trying to get SSL cert from a CA authority to work in Docker


(Okey Uchendu) #1

I’m running OpenEMR Cloud Express Plus on AWS.
Everything is up and running. I can connect to openEMR with no problems on https. But it’s using the self-signed cert which browsers still display warning message about the site not being secured.
I can’t figure out how to get a signed cert (from letsencrypt, namecheap etc) to work with the docker containers. I’m new to docker containers so please forgive me if my questions are not clear.
If someone could give me a step by step guide on getting the Signed SSL cert installed and working, I’d really really appreciate.

Thanks


(Stephen Waite) #2

Hi @chancubed


(Okey Uchendu) #3

Hi @stephenwaite

I already went through that link and tried the method listed under letsencrypt ssl certificate.
I edited the docker-compose.yml and added the environment Variables DOMAIN and EMAIL as stated. Then ran docker-compose again and there were no errors. After restarting, couldn’t connect to my instance anymore on https or http.
If i remove those environment variables and run docker-compose, I’m able to connect again.
Not sure what I’m doing wrong.

Thanks for the fast response


(Stephen Waite) #4

hi @chancubed, does the email match what is listed as the administrative contact for the domain?


(Okey Uchendu) #5

Hi @stephenwaite , it wasn’t when I ran it. I’ll try it with the email registered with the domain. I’ll post the outcome on here. Thanks a lot.


(Okey Uchendu) #6

Hi @stephenwaite , that did the trick. I switched it to the same email I used to register the domain like you suggested and it worked perfectly.
Thank you so much.