Step 3 installation problem

install

(Sombi Willingtone) #1

i have this problem on window installation
Configuring OpenEMR…

Connecting to MySQL Server… OK.
Creating database… OK.
Creating user with permissions for database… OK.
Reconnecting as new user… OK.

Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\openemr\library\classes\Installer.class.php on line 558


(Robert Down, BSN, RN) #2

Hi @Sombi_Willingtone,

Try changing the PHP INI value for max_execution_time from 60 to 90


(Sombi Willingtone) #3

oh thx it worked out


(Lydia Christina) #4

i have done change the max_execute_time to 90,then there is some error again like this

ERROR. Check your login credentials. unable to execute SQL: ‘create database openemr character set utf8 collate utf8_general_ci’ due to: Can’t create database ‘openemr’; database exists


(Ken Chapple) #5

If you partially made it through the installation, setup may have already created the database, and brought you to some state that setup could not recover from. If you don’t have data you care about, you may drop the openemr database and begin the installation again with your new php.ini settings.
$ mysql -u root -p [then enter password at prompt]
$ DROP DATABASE openemr;