Some users can't send messages after updating to 5.0.2


(Robb Rich) #1

Situation
I updated to 5.0.2 last night and tested to make sure the content was working - but this morning I received a call that the majority of users are not able to send messages. I am able to do it, and there is one other employee who can. I have looked at the settings and permissions which are all the same as what I have and the other employee who can send messages. I don’t see any errors in developer tools. Could this be a simple browser cache issue? Or something more complex?

OpenEMR Version
5.0.2

Browser:
Chrome

Operating System
MacOS High Sierra (10.13.6)

Logs
In the log I can see a response to one of my test messages from one of the people who is not able to post messages - but when she responded, the form didn’t clear or signify that something happened.


(Robb Rich) #2

I did have them all clear their browser cache but that didn’t solve the issue.


(Brady Miller) #3

Hi @apothik ,
Any more specifics (ie. what do they see when they try to send a message) or screenshots on this?
-brady


(Robb Rich) #4

Hi @brady.miller
When they go to send the message, the button doesn’t seem to be active. When they click, nothing happens visually. There aren’t any errors on the screen.

Thanks
Robb


(Robb Rich) #5

Hi @brady.miller, I will be visiting the clinic tomorrow to see first hand what is happening. Since we have one person internally who is able to send messages, I am going to have her login to her account on a different computer to see if there is something common on those computers preventing messages. If she can send, then it has to be some kind of permission or setting, but as far as I can see there aren’t any differences. I will also open up developer tools on the computers where they can’t send and make notes of any errors in the console.

Thanks
Robb


(Robb Rich) #6

Hi @brady.miller,
I didn’t get into the clinic this morning, but I did have them test a few things.

When the employee who is able to send messages from her computer logged into her account on a different computer, she was no longer able to send. So that should eliminate a permissions issue, correct?

I had them open developer tools and they sent me an image of the errors on a computer that is not able to send. That is attached. These errors are not showing on my computer or on the computer where the employee is able to send messages.

All employees are using Windows 10 based computers. Some are Surface Pro, some are Lenovo. All are on the same version of Windows 10. And all are using Chrome, and I believe it’s the same version… I am checking on that.

Thanks
Robb


(Robb Rich) #7

Hi @brady.miller,
I had some maintenance to do on one of the computers, so I have been able to verify when I login with my account, I am unable to send messages from this computer, even though I am able to send them from mine.

I am not sure if it’s all stemming from the validate_modified.js:113 (for Unknown validator futureDate) or if it’s something else. Reloading the messages directory, the library directory, and the public/assets directory did clear some of the errors from the previous screen.

The attached screenshot shows the error that pops up when I click the ‘Send Message’ button. I am able to send from my Mac with the same version of Chrome as the computer where I am unable to send (though that one is the most recent Windows 10).

There is one employee who is able to send messages on her computer, but when she logs in to another computer she is unable to - the same behavior I have experienced when logging in to one of their computers with my account. As far as I can tell, there isn’t anything different in their computer environments or their account settings.


(Robb Rich) #8

Hi @brady.miller
We just ran a few other tests. One was to have someone who couldn’t send a message in Chrome login to the EMR from a different browser. That switch allowed them to send messages. Next I logged in to the computer where I was not able to send and loaded the EMR through kproxy.com and tested. I could send a message without any errors on the proxy server. So there is definitely something going on within the normal Chrome browser that is not happening on my computer or the one Windows computer that can currently send messages. I do see that sometimes developer tools will mark some items in the error as ‘debugger://VMP839 validate_modified.js:113’

Any thoughts? This is really strange.

Thanks
Robb


(Robb Rich) #9

Hi @brady.miller
I have fixed the issue but wanted to document here what I needed to do just in case anyone else experiences the same problems.

Open ‘Settings’ in Chrome and select ‘Advanced’ from the menu on the left. Choose ‘Reset and clean up’ at the bottom of that menu and then do a ‘Restore settings to original defaults’

This has worked for every computer that was having issues. I’m not quite sure what was stored in there, but once it cleared then the messaging worked as expected.

Thanks
Robb


(Brady Miller) #10

hi @apothik ,
Thanks for the followup. Good to hear you got things back up.
-brady