Snowmed and RxNorm external load unable to extract the file

I’m trying to install the and files. OpenEMR version 7.0.1 recognizes both files. But on clicking install I get a popup titled “Successfully upgraded SNOMED” with the message “error: unable to extract files”. I added the Snomed file to supported_external_downloads with the MD5 hash to no avail.

Directions to fix would be much appreciated as we can’t operate without the codes.

You must install php-zip php-library

apt install php-zip php-library
yum install php-zip php-library

1 Like

Hi Luis, thank you for the reply. php-zip was installed at set up. There is no php-library that I can find for Unbutu 22.04 (jammy). Running php 8.0.

You’re right, I use alma linux, I thought it would be the same. Have you already tried it only with php-zip installed?

Yes. php-zip was installed when I set up the server 2 months ago. I uploaded the snomed zip to the correct directory and OpenEMR recognizes it. It just can’t extract it. Again, it’s the It would not recognmize the US only version.

I don’t know what problem it could be without looking at logs. Make sure that the owner of the zip file is www-data or nginx, according to your web service.

On Ubuntu, you will need to install the packages: php-zip, php-pclzip, & php8.0-zip (if PHP8.0 is your active version).
I have not tested the latest release of the SNOMED files yet with OpenEMR V7, it’s possible the newest source files have a different internal structure that the loader library isn’t ready to handle.
And yes, the US versions have never worked, that is to be expected. One other slim possibility, check the permissions on your /tmp folder, the extracted files will be placed there for parsing during the load process, so if for some reason your web server can’t write to it, then it will recognize the file but be unable to unzip the archive and read the data files inside.