Read about OpenEMR's Response to the COVID-19 Pandemic at https://www.open-emr.org/covid19/

Sms with 5.0.2 still unable to enable the text feature

Other than upgrading to the 5.0.2 and the patch, what additionally needs to be installed or edited to use the sms feature, i currently do not see the option to enable the sms feature, any help would be appreciated

The only SMS feature used by module is for appointment notification handled through the Modules Action menu.
There is not a texting widget.

I’m sorry, yes that is the one that i’m referring to; however, i’m not getting an option to enable it

Both Fax and SMS is auto enabled after install to Twilio client. To change to RingCentral then Globals->Modules.
Then to access module then top menu Modules->Fax Module
Then Modules Action menu.

Did you install module after composer install? That is done in Modules->Manage Modules

That is the step that i missed, would you happen to have a link here explaining installing composer?

I’m sorry, not right off. Our buddy Brady seems to have that kind of stuff at the ready. I suspect if you check out our dev demo wiki it’d might be there or web search for your o.s.

thank you, i appreciate it

If just using SMS, i’d go with Twilio. RC has better Fax but more difficult to setup on RC end.

i ran the faxsms file from github in composer, it went through with no errors; however, i still do not seem to see the modules option under global

ugh Sorry @harmone75 those instruction are from before I made FaxSms into a module so you’re missing a step ie

  • goto top menu Modules-Manage Modules
  • goto unregistered tab. find Open EMR Fax and click Register
  • go back to Register tab click install then enable
  • log out then in
  • goto Modules->Fax Sms (forgot what I named in 502)

Thank you i’m missing the fax and sms module so i must have missed a step i need to retrace my steps on that on, i did have one question regarding this step, all those show copied in the documents folder, when originally they are in the default folder, is that step correct?
old/openemr/sites/default/documents (COPY TO) => openemr/sites/default/documents

old/openemr/sites/default/edi (COPY TO) => openemr/sites/default/documents/edi

old/openemr/sites/default/era (COPY TO) => openemr/sites/default/documents/era

old/openemr/sites/default/letter_templates/custom_pdf.php (COPY TO) => openemr/sites/default/custom_pdf.php

old/openemr/sites/default/letter_templates (COPY TO) => openemr/sites/default/documents/letter_templates

old/openemr/sites/default/procedure_results (COPY TO) => openemr/sites/default/documents/procedure_results

v502 changed those file locations so they look right…

Thank you i will redo the update, i seem to still have on 7 unregistered options, missing the fax and sms option

@harmone75 @ncavalier
For now just get your v502 stable. I’m looking now at backporting my v2.0.0 for oe 5.0.3 module to v1.2.0 for 5.0.2.
It has reworked credentials and improved installer. So give me a day. I’m also looking at allowing SMS only. Furthermore, i’ve taken a look at eFax which has a SOAP XDS XML type of interface and if I can do without using secure sockets(VPN) via HTTP then maybe!!!

I’m just really swapped but maybe I can get this done.

1 Like

Thank you, i will wait for that update

Hi,
We’ve used Twilio for SMS patient reminders since 2015, the reporting inside openemr never worked but the text messages were sent out reliably. The code I cobbled together 5 years ago won’t work in 5.0.2-2.
I have no FAX and SMS Module listed under Unregistered or Registered. And no clue is given to the location of the files mentioned in this thread or on the wiki I found searching for “twilio”. So can anyone tell me where can I find the files for this? Our Twillio account is languishing away unused and our patients are missing their appointments now that they’re no longer getting their text reminders. Thanks in advance to;.
@sjpadgett @harmone75

David

New fax/sms hasn’t any effect on old notifications as new is not even installed in openemr tree by default.
Check out: Another new feature for v5.0.2(1): Fax with SMS notification module

Jerry,
Judging from your response, perhaps I didn’t make myself clear enough;
I understand that the new fax/sms feature in v5.x.x isn’t installed by default as evidenced by the failure when I tried to run; “composer require openemr/oe-module-faxsms:1.2.0” - which returns “command not found”. Obviously, as you stated; it’s a guide not a detailed procedure and there is a lot more to installing this than the “help” file tells me.

I managed to get something like this partially working back in 2013 with the files provided by Fayyaz Kasmani, and while the SMS sending itself was reliable, the old code’s reporting of sent sms reminders was wonky, so I didn’t want to move that into my new server. As a work-around, we’d look in our Twilio account, but I don’t want to continue down that road.

I seek your assistance in getting this new version for Twilio running at 100% on my system and I will gladly write up a detailed procedure and test it for the DYI folks who could really use this feature.

As directed, I checked out the link you sent and then downloaded the files from your repository, but
I have no clue about what “composer” is or does and there is no man page for it. Getting this to fly shouldn’t be a problem for me, I just need a push in the right direction with the “composer” thing.

I had a Virtual Server set up on port 80 to serve up the “sendnotifications.php” file for Twilio, and I’m guessing that will also still be required, unless there is a newer/better method available now.
TIA,
David

hi @hitechelp, try following https://getcomposer.org/doc/00-intro.md

@stephenwaite
Apparently my level of expertise is insufficient to get the Composer installer to run correctly.

At the CLI; david@openemr openemr]# /var/www/html/openemr/installer

This is what I get;

/var/www/html/openemr/installer: 1: /var/www/html/openemr/installer: cannot open ?php: No such file
/var/www/html/openemr/installer: 3: /var/www/html/openemr/installer: /bin: Permission denied
/var/www/html/openemr/installer: 4: /var/www/html/openemr/installer: 5-0-2-Patch-3.zip: not found
/var/www/html/openemr/installer: 5: /var/www/html/openemr/installer: 5-0-2-Patch-3.zip: not found
/var/www/html/openemr/installer: 6: /var/www/html/openemr/installer: Syntax error: word unexpected (expecting “)”)

Sure glad I had already installed the patches and deleted the zip files.
What now?