Do you use or administer OpenEMR? Take the General Satisfaction Survey to help improve the product

SMS text with ring central

I have my text app in production and i have entered my credentials within the emr portal however, i received this error, has anyone experienced this error?

error: “invalid_client”|

errors
0:
|errorCode:“OAU-113”|
|message:“No redirect uri is registered for the client”|
|error_description:“No redirect uri is registered for the client”|

1 Like

did you get this working? I am having the same error message.

The oauth2 login has an issue but unsure recent version is not working still, I’m getting ready to do a new release fixing up ringcentral by tomorrow eve.
Added new feature to sms like replying to sms from log:

Plus adding event listeners for portal secure messaging and either patient demographics or reminders.

oauth2 is now only way to sign in to RC.

This error is because the oauth login redirect url doesn’t exist in RC account, oe account setup or both.
It should be something like:

1 Like

No, i haven’t gotten it to work yet

@juggernautsei @harmone75
Here is a testing patch for the RC service implementation if you’ll be so kind and test for me.
It includes some fixes to core code to support the fax modules.
RC oauth appears to now behave itself. So lots of hidden gems in this next release.

rc_fax_patch_v6.zip (34.4 KB)

1 Like

I will get this installed tomorrow and test it

Remember this is for openemr v6.0. It will break on v5.0.2

I installed the patch. I used the URI you suggested and that error message when away. I copied this out of the log. I don’t know if it is of value. When we try to send a fax we get the similar error Service Denies Access.

 [Wed Feb 24 21:32:07.516802 2021] [php7:notice] [pid 261932] [client 70.184.171.187:54330] oe-module-faxsmsdoes not have a controller object, referer: https://ehr.med.com/interface/modules/zend_modules/public/Installer
 [Wed Feb 24 21:32:07.557562 2021] [php7:notice] [pid 261932] [client 70.184.171.187:54330] PHP Notice:  Undefined property: Installer\\Controller\\InstallerController::$helperObject in /var/www/html/boss/interface/modules/zend_modules/module/Installer/src/Installer/Controller/InstallerController.php on line 316, referer: https://ehr.med.com/interface/modules/zend_modules/public/Installer
 [Wed Feb 24 21:33:57.769173 2021] [php7:notice] [pid 258860] [client 69.28.93.63:16376] PHP Notice:  Undefined variable: recipient_phone in /var/www/html/boss/interface/modules/custom_modules/oe-module-faxsms/contact.php on line 42, referer: https://ehr.med.com/interface/main/tabs/main.php?token_main=mXTriUqQRlEspMe3aQQcjAySZCMpg7IzSjYGRTBU

fyi as I just got caught. Don’t forget to set the Production flag on or off in your account credentials setup dialog depending on your RC account.

I’m not seeing the option to input the settings after i extracted the file and enabled it under manage modules. Under administration is shows modules, but nothing to configure

It means you’re not logged in to RC.
Did you get a oauth dialog? You should get a log in button next to refresh when you get that error also.
Hope you didn’t use the exact redirect url I showed as that’s for my server. You have to replace my domain with yours. Also, that same url has to be setup in your RC account settings. App needs to have Auth Code and Refresh Token set.


You need to be sure you’re on the 2.2.0-dev version. If you upgraded openemr to v6 then you need to reinstall faxsms for v6 version. Also try to Disable click trash can then go to unregistered to reinstall the setup. Do this too if you decide to reinstall from composer ie do trash can the composer install.

Can you reach setup from the Fax UI Action->Account Credentials

Yes i’m on version 6, so i will go and get the faxsms for that version and give it a try

Are you going to install with composer?

Thinking about it I wonder if an account is setup for password it may still work w/o oauth login. i.e. same as earlier version of module. R.C forces a more rigorous turn up for server password which is why I changed over to Auth code grant. It should work for legacy password grant but most folks already have a RC account where you don’t have to setup production testing with RC.

Do you have the link to the thread for the fax module for V6?

openemr/oe-module-faxsms: Fax and SMS feature for OpenEMR
Do with composer install. Not sure about using the download, never tried but may be okay.

You must install via composer because I haven’t released the dev version yet so download gives old code…
composer require “openemr/oe-module-faxsms:2.2.0-beta”

Just checked and you can download from

I get the page to authorize the app but when I select authorize the dialog box/window disappears.

Sherwin can you just give me a call now to go through this. I’m not up for all the typing…

@sjpadgett, finding where the system changes the session did not take long. The moment the authorize button is selected the system loads a new session and the multi site session is lost. The system returns to default as the session ID. I turned on the debug in the globals to alert when the session change.

I checked when the rcauth.php page loads the session site id is set to the multi site that I am logged into.

The thing that came to mind to solve this is to drop a session cookie. Retrieve the cookie to see if it matches the site id of the new session if it does not match use the cookie site id.

@juggernautsei
Nope, just add ?site=yoursite to the redirect urls i.e ....rcauth.php?site=multisite
that’ll fix it…