Do you use or administer OpenEMR? Take the General Satisfaction Survey to help improve the product

RxNorm appears not working in Docker

Hello All,

I’m testing 5.0.2 in Docker and hoping to get some answer about the aforementioned topic.

I downloaded the RxNorm_full_11022020.zip from the NIH website and copied it into the openemr container at contrib/rxnorm. Then I registered it through Admin->Other->External Data Loads. The operation appeared successful as it showed the correct version under Installed Release. I also went to Admin->Lists->Code Types to enable RXCUI. The check box under the Drug column is also checked. But when I tried to add a new medication using RXCUI Medication it shows “No matching records found”.

Did I miss anything? Thanks for your help!

–Cuong

hi @chauct, we were just working on this :slight_smile:

Hi Stephen,

I did look at that post before posting my question.

I bumped the post_max_size to 300M but still got “LOAD SUCCESSFUL. Codes inserted: 0, replaced: 0”. The standardized_tables_track table is empty. Any idea where I should look next?

Thanks,
Cuong

just use the “Current Prescribable Content Monthly Release”

I had tried this before and tried again as you suggested but still not working. I even tried the July version that @PeteBoyd had much luck with.

Just to be clear, I’m using the Docker production docker-compose.yml to bring openemr up.

Thanks,
–Cuong

The solution I described used Administration > Other > Native Data Loads, not External Data Loads.

I switched to using Native Load after reading your post but the problem still persists

hi @chauct, did you restart the openemr docker after changing the php setting?

Yes. otherwise it would have showed the error “POST-Content-Length… bytes exceeds the limit of…”.

What’s the easiest way to debug openemr? I’ve worked with other languages but this would be my first foray into PHP. :slight_smile:

ok, nice, you can follow the contributing guide

1st command in step 7 will show php error logs

I’m using the crudest form of debugging: error_log :wink:

It appears there’s something wrong with the POST uploads in Docker as it shows $_FILES[‘form_file’][‘size’] is ZERO and $_FILES[‘form_file’][‘tmp_name’] empty.

ok, some folks are using phpstorm with xdebug, step 19

did you check this setting in php?

    mysqli.allow_local_infile = On

Yes, It is ON.

Any idea why the upload file does not show up?

nope, should be fine, just tested on https://six.openemr.io/c/openemr/index.php with the weekly rxnorm

I have tested this on 2 different computers both running Ubuntu 20.04 with identical problem.

I just tried to upload a medical record (image type) and it works. Strange!

1 Like

Okay, I think the problem may appear to be a MIME related. I extracted the RXNCONSO.RRF and upload worked!

1 Like

Is this a browser thing or something needs to be changed on the server side?