Root Credential error when installing through Docker

Hello
I’m trying to install OpenEMR v6.1.0 official image through Docker and ran in to a issue.
on step 2 I enter all info for MariaDB root that I already installed and running on the same machine, but I get: Connecting to MySQL Server… ERROR. Check your login credentials. unable to connect to database as root.
I tried using localhos and ip address with correct port and 100% sure that root credentials are correct for that server but still same error. question: is there it’s own database running on this docker image and installation script is trying to connect to that database? if so is there a default root credentials? any suggestions? thanks

Hi @George_Zera, please see this example docker compose .

1 Like

Hi Stephen
Thanks for link, but still against same error using suggestions from that page.
so please correct me if I’m wrong
on step 1 should I choose: Have setup create the database or I have already created the database?
I went with Have setup create the database and entered Server Host: localhost, Server Port:3306, Database Name:openemr, Login Name: openemr, Password:openemr, Name for Root Account: root pass: root, User Hostname: mysql,
what am I doing wrong?

that docker-compose.yml example above does an auto-setup, here’s the settings for adding another site:

I can’t figure out how to use that auto setup thing. I’m new to Docker environment and new to openemr itself too. would you please help me out with that? thanks

copy the text into a docker-compose.yml file or use the attached
docker-compose.yml (1005 Bytes)
then run
docker-compose up -d and give it 5 mins to build, then you can login at localhost with admin pass

Hello @George_Zera

I would love to assist you.

PM sent

BR

Trish

Hello @Trishhhh @stephenwaite
thanks for taking time to help me out, but I’m kind of lost, so do I run that docker-compose.yml inside the container terminal? or how is it going to work? if this file so important for installing openemr why isn’t it included in docker image? as I mentioned I’m new to docker environment and would need more detailed guide if you can please.
so my Docker is running on synology storage server DS1813+ if that makes any sense. thanks

hi @George_Zera, yes, from a terminal. The dockers are meant to be modular and that’s where these compose files come in to tie them together with other dockers and data storage.