Read about OpenEMR's Response to the COVID-19 Pandemic at https://www.open-emr.org/covid19/

Resolution of error logging in on initial installation

Hi. I just yesterday installed Open EMR on a Dell Laptop updated to Windows 10 when update first available. I installed using xampp package downloading 5.0.2 from SourceForge although after mistakenly downloading 5.0.1 later deleted.
I got everything installed but when came to sign in page of OpenEMR, an error which I noted to have been a previously reported issue came up regarding missing bool info in line 44 concerning linear array of C:\xampp\htdocs\openemr\library\translation.inc.php. A search showed advice to edit php.ini to turn off errors. There are actually several parameters in my php,ini for stipulating handling of errors. No matter how many of these error reportings I turned off(restarting Apache after each edit in php.ini, I kept getting this error back. Adventurous novice(possibly over-characterization) that I am, I then attempted editing that folder above but using Notebook to open that folder found no numbering of lines and fiddled with line 248 instead which also involves an array and that produced an error which stopped me being able to open the sign in to OpenEMR. I have snips of the folder and most recent error line but now sure how to attach then here. I think that if you can tell me how to edit lines 44 and 248 regarding array parameter in each instance in the above folder…\translation.inc.php, I will probably be okay to then restart Apache and go to http:/localhost.openemr. Please tell me if I am wrong.

I am new to community interactions online. Hope is appropriate to direct my above communique(can you see it?) to @brady.miller as opposed to just hanging it out there for whomever to respond.
Also I had forgotten to include snip of the most recent error line and am adding here.

Revising the issue, I deleted openemr (5.0.2 although no longer named as such) then downloaded again and unzipped 5.0.2 back to C:\xampp\htdocs able to again go thru steps of OpenEMR setup only to discover same original error on opening http://localhost/openemr ie Notice : Trying to access array offset on value of type bool in C:\xampp\htdocs\openemr\library\translation.inc.php on line 44
and having downloaded Atom as editor, but unable to configure a working linter found the offending line 44 to read ": $string = $row[‘definition’];
Many have viewed but probably found the original post overwhelming. Hopefully someone can now help me resolve (@brady.miller. )
Again I am using Xampp for php and sql and downloaded openemr5.0.2 from sourceforge in Windows 10. Reviewing posts, I note that Windows 10 Home does not meet requirements for Docker desktop in Windows and my old computer with 2 GB RAM is sufficient for Mint but not for Ubuntu LTS. I am a retired FP MD who basically only wants a basic system as I am still primary provider for myself and my wife. The demo seems to fit that bill well. Should I back off to 5.0.1? I should mention that C:\xampp\php contains at least 2 editable files for …php.ini(production and development) and one phy designated config --all 3 identical as well as the config section of php.ini in Apache. In each there are at least 3 lines related to handling of errors: turning all except logging errors off returns same error.

This same error was addressed in a Feb thread but most of the effort was spent finding the loaded configuration of php.ini. without explaining the error report editing(referenced onlyh as looking at faq). In my case, according to my Xampp Dashboard below, mine is one of the 2 C:\xampp\php\php.ini files, both of which I have edited to turn off error reporting other than error logging. Restarted Apache after each effort but the error for line 44 does not disappear. Do we need to edit line 44? Also I only need English. Would eliminating the …openemr\library\translation.inc.php solve anything?
Dashboard:

PHP Version 7.4.2

System Windows NT DON-PC 10.0 build 17134 (Windows 10) AMD64
Build Date Jan 21 2020 17:46:05
Compiler Visual C++ 2017
Architecture x64
Configure Command cscript /nologo configure.js “–enable-snapshot-build” “–enable-debug-pack” “–with-pdo-oci=c:\php-snap-build\deps_aux\oracle\x64\instantclient_12_1\sdk,shared” “–with-oci8-12c=c:\php-snap-build\deps_aux\oracle\x64\instantclient_12_1\sdk,shared” “–enable-object-out-dir=…/obj/” “–enable-com-dotnet=shared” “–without-analyzer” “–with-pgo”
Server API Apache 2.0 Handler
Virtual Directory Support enabled
Configuration File (php.ini) Path C:\WINDOWS
Loaded Configuration File C:\xampp\php\php.ini
Scan this dir for additional .ini files (none)
Additional .ini files parsed (none)
PHP API 20190902
PHP Extension 20190902
Zend Extension 320190902
Zend Extension Build API320190902,TS,VC15
PHP Extension Build API20190902,TS,VC15
Debug Build no
Thread Safety enabled
Thread API Windows Threads
Zend Signal Handling disabled
Zend Memory Manager enabled
Zend Multibyte Support provided by mbstring
IPv6 Support enabled
DTrace Support disabled
Registered PHP Streams php, file, glob, data, http, ftp, zip, compress.zlib, compress.bzip2, https, ftps, phar
Registered Stream Socket Transports tcp, udp, ssl, tls, tlsv1.0, tlsv1.1, tlsv1.2, tlsv1.3
Registered Stream Filters convert.iconv., string.rot13, string.toupper, string.tolower, string.strip_tags, convert., consumed, dechunk, zlib., bzip2.

hi @XAM-admin-78, what mysql version are you running in that xampp?

Mysql looks like version 10.4.11.0 according to file C:\xampp\mysql\bin\mysql_install_plugin created 2/29/2020? Also curious that the Xampp dashboard shows my system to have AMD64 but laptop really has Intel Corei5; doubt that matters.

ok, thanks, can you post a screenshot of what the login page looks like? wondering if you need to follow the recommended php.ini settings

Here is the screenshot. As stated on my prior post, I have tried to follow the php.ini editing instructions, the ini is far more extensive than the instructions given for them including multiple opportunities to turn off error reporting and according to my prior post, among multiple locations, the loaded configuration is in the C:\xampp\php\php.ini file (there are 2 identicals in that category and I edited both with the understanding that this is the development version but I edited for both development and production. I did leave error logging on. There is now an additional error for line 149 which according to atom:

{

as end of this block:

}
// Added 6-2009 by BM for translation of patient form (notes) titles
// (when applicable)
// Only translates if the $GLOBALS[‘translate_form_titles’] is set to true.
function xl_form_title($constant, $mode = ‘r’, $prepend = ‘’, $append = ‘’)
{

yep, turn off notices in your xampp php.ini per above link

Will repeat the snip image as the first as entire window does not scroll:

I have turned off all seemingly appropriate error reporting in what is supposed to be the loaded configuration of php.ini. What specific notifications need I turn off. As thus far after doing this and restarting Apache,entering http:/localhost/openemr returns the same error but only pertaining to line 44 in …\translation.php.inc.

Okay; I discovered via a YouTube instruction that I edit php.ini by editing the http line turning off all error notification except logging then restarting Apache and http:/hocalhost/openemr now brought up log in page without error notice and now was able to progress to the registration page but then on attempting log in, OpenEMR is not accepting my user/password. What now?

if you remember your username you can run this from phpmyadmin or the mysql command line

UPDATE users_secure SET password = '$2a$05$MKtnxYsfFPlb2mOW7Qzq2Oz61S26s5E80Yd60lKdX4Wy3PBdEufNu', salt = '$2a$05$MKtnxYsfFPlb2mOW7Qzq2b$' WHERE id  = '1'

which will reset the password to pass

if you don’t remember your username you will need another query

When I tried the advised command under the SQL tab(the only place there I could find to enter a command) in phpMyAdmin graphic interface, I got syntax error for the command you advised(copied and pasted).

Also I had saved my user and passwords for EMR and root so not a matter of losing them.

probably easier to just reinstall, good practice :slight_smile:

Reinstall Xampp and OpenEMR or more limited reinstalls? 5.0.1 or 5.0.2 for most basic but stable configuration? Not to be mean, but the superficial instructions given would probably not be needed for someone to whom the seemingly assumed skill levels are there, and not all that useful to those more new to this.

just openemr 5.0.2, assuming xampp is fine, sorry if limited support but don’t have access to windows

instructions

I deleted openemr 5.0.2 and then redownloaded, unzipped and extracted to C:\xampp\htdocs and went thru the OpenEMR set up having previously edited php.ini to turn off error reporting and error displays as well as other recommended php.ini recommendations and upon log in page coming up, no errors were present BUT would on clicking log on displayed invalid user/password.
I then deleted both openemr and the corresponding downloaded xampp(deleting xampp required logging in as administrator PLUS turning off UAC in Windows to complete without requirements for administrator permissions).
I am now considering the Xampp package for 5.0.1 since this appears to be the last stable release and my needs for this system are minimal but interested in you opinion.