Do you use or administer OpenEMR? Take the General Satisfaction Survey to help improve the product

Procedure Providers

Greetings!

I’m testing 5.0.2 with patch 4 and running into an issue with adding new Procedure Providers. It appears only providers with Lab Service type can be added as all other types do not show up in the drop down list. I also tried the Nightly build demo and it seems to have the same behavior. Can someone confirm this?

Thanks,
Cuong

Hi @chauct

The providers mentioned under procedures are lab providers and not the providers (users) in the OpenEMR.

The lab providers are the one who provide lab specific services that is mapped with OpenEMR.

Hope this may help you.

Thanks,
ViSolve

Hi @visolve

Thanks for replying. The provider in question was an external Imaging Service not an internal user provider. In fact I’ve tried a few other types e.g. Specialist, Immunization Service, etc. and none work.

– Cuong

hi @chauct, it’s hard coded will see if can patch it while am in there on another assignment but feel free to hack away on your own version :slight_smile:

        $lab_org_query = "SELECT id, organization FROM users WHERE abook_type LIKE '%ord_%'";

Hi @stephenwaite, thanks for confirming it. I’m too green to hack things :wink: but will definitely contribute when I know my way around this thing.

1 Like