Portal


(Jerry P) #5

This is valid uri but where is the domain. Is this from console error? Also, have you tried reinstall of portal directory with latest. Relative path’ing was an issue but was addressed few months ago. I’ve tested ubuntu 14.04, 16.04 and windows 10 but not 17. Also tested through php 7.1. Can you log into portal and access profile?


(Gerardo) #6

i have the same problem for patient self registration, do you can help me to resolve?! because I have the same problema like @rmagauran but I have installed server Amazon Linux server 2 AIM2
I send you a screen capture of problem from mi site thank you
|690x458


(Jerry P) #7

I’ve just retested and works okay for me. Have you installed 5.0.1 patches? Check here: https://www.open-emr.org/wiki/index.php/OpenEMR_Patches and be careful if you have custom code. The files for portal are what you need so just use them if you need to. Just let me know what patch version you are on now if any for others info.


(Gerardo) #8

hi @sjpadgett i follow your advices , I installed patch for 5.0.1 but the problem still there


i uploaded a small videos showing the problem
https://drive.google.com/file/d/16jAg_HEZcdotit-Md2sawTNIy-PMe0bu/view?usp=sharing

http://sendvid.com/rrv2ozro

(Jerry P) #9

Has to be something with your install. Check file permissions and user:group permissions in openemr/portal/patient directory if on ubuntu. Check browser console to see if the fetch returns a 404 or 500 error. Check php error logs for clues.


(Jerry P) #10

Ray if I remember correctly, you got this to work when you reinstalled. Is that correct?


(Gerardo) #11

I saw portal folder, the folder has permission 775 and ec2-user and apache group
but… the files inside the folder “Portal” has diferentes permission and groups, some files has permission 644 with ec2-user and apache group, and other files has permission 664 with ec2-user and groups ec2-user, is it correct ?
I’ll send you a screen capture


(Jerry P) #12

I assume this is Alpine in a docker container. No matter but i’m not sure what is in the apache group so suggest doing a recursive chown -R ec2-user:ec2-user on portal directory.
edit: are you able to log in as portal patient?


(R Magauran) #13

Still not working but I have not loaded the latest files.


(Jerry P) #14

Okay thanks. I don’t understand what is missing. All my testing works okay so i’ll try test some more.


(Stephen Waite) #15

hi Jerry, if I remember from another thread that the web server doesn’t like the leading /openemr in the path name?


(Jerry P) #16

That’s true but i’m pretty sure one of the patches adds a url test for making sure web_root is properly parsed for a relative endpoint. The browser should take care of the rest of inserting correct domain. @geromoss Really do need the browser console error to know for sure.


(Jerry P) #17

I just retested again against all our demos in demo farm including Alpine 3.7. All are okay. @geromoss Can you e-mail me your sites portal url so I can test myself? sjpadgett@gmail.com


(Gerardo) #18

i changed permission on Portal directory for ec2-user:ec2-user and still the same problem, i’m not using Alpine neither Docker container, just downloaded packed from oficial website OpenEMR version http://sourceforge.net/projects/openemr/files/OpenEMR%20Current/5.0.1.6/openemr-5.0.1.tar.gz
thank you @sjpadgett i send you an email with the link


(R Magauran) #19

I used a second browser to avoid session conflicts and it still failed. However I noticed in openemr, when I reset the browser credentials for my test user, the username in the pop-up was different than the username in the demographics for CMS Portal Login for this patient. When I changed this CMS Portal Login value to match the one autocreated (?), I was able to get it to work… Does that make sense?


(Jerry P) #20

I do know that only one portal should be enabled. I’ll check code but maybe i’m grabbing the wrong credentials. Anyway this is a clue, thanks. @geromoss Have you got more than one portal enabled in Globals?


(Jerry P) #21

@geromoss For some reason portal can’t access the patientdata restful endpoint. Must be something with server config. Maybe need to add server directory permissions for openemr/portal/patient directory or .htaccess is turn off. Are you behind a proxy, reverse proxy or load balancer that may be rewriting the url? Be sure to uncheck Portal Uses Server Base Path (internal) in Globals now that you did some changes and try. Once again, can you log in as a portal patient? Otherwise, I don’t know how to help.
@rmagauran Do you know if cms portal uses patient_access_onsite for passwords? If so then that’s an issue for running dual portals which by the way, the demo farm has all portals turned on so that may not be an issue.
Anyway, I can’t recreate so i’m at a loss.


(Brady Miller) #22

Hi,
All portals should be able to run simultaneously.
Left related comments on this thread:


-brady


(Ajit Singh) #23

not working on demo server while in local system it is working fine
/openemr/portal/patient/onsitedocuments?pid=10
this above url is giving error 404
can anyone suggest please ?


(Gerardo) #24

i Solved it!
the problem is Amazon Ec2 has desactivated .htaccess for default and some file in folder openEmr have different permission and user group for default , so what i do was: change configuration in apache, delete complete folder OpenEMR, download again OpenEMER, unzip it and change permission and group recursive files and folders OpenEMR.
Details Instructions:

  1. go to configuration Apache (in my server Amazon Ec2 is located in /etc/httpd/conf/httpd.conf) sudo nano /etc/httpd/conf/httpd.conf
  2. go to DocumentRoot “/var/www/html” and looking for AllowOverride None
  3. changed AllowOverride None to AllowOverride All <- very important
  4. go to terminal /var/www/html and delete folder openEMR
  5. use wget http://www…tar.gz to download openEMR last version
  6. follow instruction to unzip OpenEMR zip in folder
  7. very importante change permission and group folder OpenEMR that correspond, in my case i use : sudo chown -R ec2-user:apache /var/www/html/openemr
  8. go to openEmr page setup.php and following instructions
  9. FIX IT!!! now patients have self-registration
    THANK TO EVERYDOY for your HELP , i think you should add text in install instructions page wiki use a command recursive like: sudo chown -R [user]:[group] /var/www/html/openemr because for some reason when unzip openEMR it has differents groups and permission default in some files PHP and CSS
    thank you



Portal v2 Registration never goes to step 2