Planning for OpenEMR 5.0.2 release


(Ralf Lukner MD PhD) #21

It (with or without demo data) doesn’t work on Mac Chrome – I log in as physician and it doesn’t take me to anything …


(Stephen Waite) #22

good catch @Ralf_Lukner , it doesn’t look like there are any valid users other than admin

the site with demo data has them so maybe when the above demo resets overnight the users will be restored


(Stephen Waite) #23

looks like that’s all it took to break it :slight_smile:


(Brady Miller) #24

Hi,

I just checked this and I was able to login with physician:physician on the site with demo data.

Is this still not working for you. If so, what browser are you using?


(Stephen Waite) #25

looks like there’s a problem with mac os mozilla and chrome for the physician login at https://www.open-emr.org/wiki/index.php/Development_Demo#Demo_.28Alpine_3.10_-_uses_php_7.3.29
and when you login as admin it doesn’t show other users


(Brady Miller) #26

Strange. When you login as admin to the demo with data, do you see this:

btw, this is demo link of that screenshot:
https://six.openemr.io/a/openemr/interface/main/tabs/main.php?token_main=9jQ6u2WMcveYprw2vTxkvrKfcacXHevmDlPOxBwP


(Brady Miller) #27

Hi @stephenwaite and @Ralf_Lukner ,
I brought in a fix 2 days ago for session/cookie (a comma in the session id was causing problems, which should now be fixed, and guessing was causing issues with your browsers). Please retest and tell me that the issue has gone away :slight_smile:
-brady


(Brady Miller) #28

Hi,

I just branched rel-502 in github repository, and we are about 2 weeks from the 5.0.2 release.

There are now 5.0.2 development specific demos and packages (packages are built daily) along with install/upgrade instructions. Please test these all.

The OpenEMR 5.0.2 development demos are here (4 environments each with a demo with and without demo data):
https://www.open-emr.org/wiki/index.php/Development_5.0.2_Demo

The OpenEMR 5.0.2 development package builds (and install/upgrade instruction sets) can be found here:
https://www.open-emr.org/wiki/index.php/OpenEMR_Downloads#Daily_snapshots

You can follow the progress of the release process here (and feel free to help out with anything):
https://www.open-emr.org/wiki/index.php/QA/Release_Process#Version_5.0.2

-brady


(Stephen Waite) #29

no change :grimacing:
still no users listing under admin login and physician login says invalid username/password

with ubuntu firefox https://six.openemr.io/openemr/interface/login/login.php?site=default admin login shows only admin user

also happening at https://eight.openemr.io/openemr/interface/login/login.php?site=default, so it’s the master branch that has a problem loading the users


(Brady Miller) #30

Hi,

Chest pain… :slight_smile:

How about these 2 demos in https://www.open-emr.org/wiki/index.php/Development_5.0.2_Demo :
https://six.openemr.io/c/openemr/index.php
https://seven.openemr.io/f/openemr/index.php

(ensure you have that ‘c’ or that ‘f’ in the path)