PHP fatal error: call to undefined function mysqli_query


(Venu Julapalli) #1

Hello friends,

My staff and I have not been able to log in to OpenEMR abruptly as of this morning. This is what the apache2 error.log is saying:

[Wed Nov 07 20:10:41.295828 2018] [:error] [pid 2308] [client 10.8.0.6:45792] PHP Fatal error: Uncaught Error: Call to undefined function mysqli_query() in /var/www/openemr/vendor/adodb/adodb-php/drivers/adodb-mysqli.inc.php:786\nStack trace:\n#0 /var/www/openemr/vendor/adodb/adodb-php/adodb.inc.php(1251): ADODB_mysqli->_query(‘SET NAMES ‘utf8…’, false)\n#1 /var/www/openemr/vendor/adodb/adodb-php/adodb.inc.php(1229): ADOConnection->_Execute(‘SET NAMES ‘utf8…’, false)\n#2 /var/www/openemr/library/ADODB_mysqli_log.php(24): ADOConnection->Execute(‘SET NAMES ‘utf8…’, false)\n#3 /var/www/openemr/library/sql.inc(53): ADODB_mysqli_log->Execute(‘SET NAMES ‘utf8…’)\n#4 /var/www/openemr/interface/globals.php(268): require_once(’/var/www/openem…’)\n#5 /var/www/openemr/interface/main/tabs/main.php(30): require_once(’/var/www/openem…’)\n#6 {main}\n thrown in /var/www/openemr/vendor/adodb/adodb-php/drivers/adodb-mysqli.inc.php on line 786

Thank you for any help.

-Venu


(Daniel) #2

Have you made any changes to the code? Perhaps some permissions have changed?


(Venu Julapalli) #3

I didn’t make any code changes or changes to permissions. I had upgraded to Ubuntu 18.04 several days prior, but it was working fine for several days after the upgrade, until just yesterday morning.


(Jerry P) #4

Looks like it wants to fail writing to logs after setting UTF8 on initial mysql pconnect. This is the first call on init so leads me to believe maybe logs may have been changed in globals causing this to show now. Just a guess though. Also, what version PHP, OpenEMR and can you connect okay to admin.php from browser?


(Venu Julapalli) #5

I erase admin.php as a recommended security measure.

I have OpenEMR 5.0.1 with Patch 6, PHP 7.2.10, and Ubuntu 18.04.1.


(Jerry P) #6

Sorry, I don’t know how to help you with this. You might see if there was an apache restart around the time this happened or anything out of ordinary(php logs should show). If sql_upgrade.php is still around try running it or reinstall admin.php to see if we can get a better error description from running it.
I’ve not seen this before. Maybe append & ~E_DEPRECATED & ~E_STRICT & ~E_USER_DEPRECATED to php.ini error_reporting= and restart apache.


(Venu Julapalli) #7

This is what I’ve been able to determine thus far. Here are my relevant syslogs and error logs:

SYSLOG
Nov 2 07:35:03 openemrhost systemd[1]: Reloading LSB: Apache2 web server.
Nov 2 07:35:03 openemrhost apache2[13444]: * Reloading Apache httpd web server apache2
Nov 2 07:35:04 openemrhost apache2[13444]: *
Nov 2 07:35:04 openemrhost systemd[1]: Reloaded LSB: Apache2 web server.
Nov 2 07:35:04 openemrhost systemd[1]: Stopping Make remote CUPS printers available locally…

ERROR LOG
[Fri Nov 02 07:35:04.225505 2018] [mpm_prefork:notice] [pid 1388] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‘ServerName’ directive globally to suppress this message
[Fri Nov 02 07:35:04.363718 2018] [ssl:warn] [pid 1388] AH01906: 127.0.1.1:5380:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Fri Nov 02 07:35:04.363835 2018] [ssl:warn] [pid 1388] AH01909: 127.0.1.1:5380:0 server certificate does NOT include an ID which matches the server name
[Fri Nov 02 07:35:04.364176 2018] [mpm_prefork:notice] [pid 1388] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured – resuming normal operations
[Fri Nov 02 07:35:04.364194 2018] [core:notice] [pid 1388] AH00094: Command line: ‘/usr/sbin/apache2’

(Able to log on to OpenEMR)

SYSLOG
Nov 3 07:35:03 openemrhost systemd[1]: Reloading LSB: Apache2 web server.
Nov 3 07:35:03 openemrhost apache2[18561]: * Reloading Apache httpd web server apache2
Nov 3 07:35:03 openemrhost apache2[18561]: *
Nov 3 07:35:03 openemrhost systemd[1]: Reloaded LSB: Apache2 web server.

ERROR LOG
[Sat Nov 03 07:35:03.793924 2018] [mpm_prefork:notice] [pid 1388] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‘ServerName’ directive globally to suppress this message
[Sat Nov 03 07:35:03.927658 2018] [ssl:warn] [pid 1388] AH01906: 127.0.1.1:5380:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sat Nov 03 07:35:03.927766 2018] [ssl:warn] [pid 1388] AH01909: 127.0.1.1:5380:0 server certificate does NOT include an ID which matches the server name
[Sat Nov 03 07:35:03.928087 2018] [mpm_prefork:notice] [pid 1388] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured – resuming normal operations
[Sat Nov 03 07:35:03.928104 2018] [core:notice] [pid 1388] AH00094: Command line: ‘/usr/sbin/apache2’

(Upgraded to Ubuntu 18.04 later that morning, still able to log on to OpenEMR after upgrade)

SYSLOG
Nov 4 00:08:26 openemrhost systemd[1]: Reloading The Apache HTTP Server.
Nov 4 00:08:26 openemrhost apachectl[5145]: AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‘ServerName’ directive globally to suppress this message
Nov 4 00:08:26 openemrhost systemd[1]: Reloaded The Apache HTTP Server.

ERROR LOG
[Sun Nov 04 00:08:26.535717 2018] [mpm_prefork:notice] [pid 1302] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‘ServerName’ directive globally to suppress this message
[Sun Nov 04 00:08:26.656981 2018] [ssl:warn] [pid 1302] AH01906: 127.0.1.1:5380:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun Nov 04 00:08:26.657028 2018] [ssl:warn] [pid 1302] AH01909: 127.0.1.1:5380:0 server certificate does NOT include an ID which matches the server name
[Sun Nov 04 00:08:26.658190 2018] [mpm_prefork:notice] [pid 1302] AH00163: Apache/2.4.29 (Ubuntu) OpenSSL/1.1.0g configured – resuming normal operations
[Sun Nov 04 00:08:26.658220 2018] [core:notice] [pid 1302] AH00094: Command line: ‘/usr/sbin/apache2’
[Sun Nov 04 00:08:26.672174 2018] [:error] [pid 5152] avahi_entry_group_add_service_strlst(“openemrhost”) failed: Local name collision

(Still able to log on to OpenEMR)

SYSLOG
Nov 5 00:05:25 openemrhost systemd[1]: Reloading The Apache HTTP Server.
Nov 5 00:05:25 openemrhost apachectl[21545]: AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‘ServerName’ directive globally to suppress this message
Nov 5 00:05:25 openemrhost systemd[1]: Reloaded The Apache HTTP Server.

ERROR LOG
[Mon Nov 05 00:05:25.427266 2018] [mpm_prefork:notice] [pid 1302] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‘ServerName’ directive globally to suppress this message
[Mon Nov 05 00:05:25.636151 2018] [ssl:warn] [pid 1302] AH01906: 127.0.1.1:5380:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Mon Nov 05 00:05:25.636193 2018] [ssl:warn] [pid 1302] AH01909: 127.0.1.1:5380:0 server certificate does NOT include an ID which matches the server name
[Mon Nov 05 00:05:25.637409 2018] [mpm_prefork:notice] [pid 1302] AH00163: Apache/2.4.29 (Ubuntu) OpenSSL/1.1.0g configured – resuming normal operations
[Mon Nov 05 00:05:25.637439 2018] [core:notice] [pid 1302] AH00094: Command line: ‘/usr/sbin/apache2’
[Mon Nov 05 00:05:25.648978 2018] [:error] [pid 21555] avahi_entry_group_add_service_strlst(“openemrhost”) failed: Local name collision

(Still able to log on to OpenEMR)

SYSLOG
Nov 6 00:06:08 openemrhost systemd[1]: Reloading The Apache HTTP Server.
Nov 6 00:06:08 openemrhost apachectl[29273]: AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‘ServerName’ directive globally to suppress this message
Nov 6 00:06:08 openemrhost systemd[1]: Reloaded The Apache HTTP Server.

ERROR LOG
[Tue Nov 06 00:06:08.555518 2018] [mpm_prefork:notice] [pid 1302] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‘ServerName’ directive globally to suppress this message
[Tue Nov 06 00:06:08.675572 2018] [ssl:warn] [pid 1302] AH01906: 127.0.1.1:5380:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Tue Nov 06 00:06:08.675610 2018] [ssl:warn] [pid 1302] AH01909: 127.0.1.1:5380:0 server certificate does NOT include an ID which matches the server name
[Tue Nov 06 00:06:08.676661 2018] [mpm_prefork:notice] [pid 1302] AH00163: Apache/2.4.29 (Ubuntu) OpenSSL/1.1.0g configured – resuming normal operations
[Tue Nov 06 00:06:08.676690 2018] [core:notice] [pid 1302] AH00094: Command line: ‘/usr/sbin/apache2’
[Tue Nov 06 00:06:08.688361 2018] [:error] [pid 29286] avahi_entry_group_add_service_strlst(“openemrhost”) failed: Local name collision
[Tue Nov 06 16:40:59.462890 2018] [:error] [pid 26679] [client 192.168.11.27:58032] PHP Deprecated: You are retrieving the service locator from within the class Installer\Controller\InstallerController. Please be aware that ServiceLocatorAwareInterface is deprecated and will be removed in version 3.0, along with the ServiceLocatorAwareInitializer. You will need to update your class to accept all dependencies at creation, either via constructor arguments or setters, and use a factory to perform the injections. in /var/www/openemr/vendor/zendframework/zend-mvc/src/Controller/AbstractController.php on line 258, referer: https://192.168.11.28:5380/openemr/interface/main/tabs/main.php

(Still able to log on to OpenEMR that morning)

SYSLOG
Nov 7 00:10:08 openemrhost systemd[1]: Reloading The Apache HTTP Server.
Nov 7 00:10:08 openemrhost apachectl[29551]: AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‘ServerName’ directive globally to suppress this message
Nov 7 00:10:08 openemrhost systemd[1]: Reloaded The Apache HTTP Server.

ERROR LOG
[Wed Nov 07 00:10:08.627546 2018] [mpm_prefork:notice] [pid 1302] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‘ServerName’ directive globally to suppress this message
[Wed Nov 07 00:10:08.765036 2018] [ssl:warn] [pid 1302] AH01906: 127.0.1.1:5380:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Wed Nov 07 00:10:08.765085 2018] [ssl:warn] [pid 1302] AH01909: 127.0.1.1:5380:0 server certificate does NOT include an ID which matches the server name
[Wed Nov 07 00:10:08.766346 2018] [mpm_prefork:notice] [pid 1302] AH00163: Apache/2.4.29 (Ubuntu) OpenSSL/1.1.0g configured – resuming normal operations
[Wed Nov 07 00:10:08.766378 2018] [core:notice] [pid 1302] AH00094: Command line: ‘/usr/sbin/apache2’
[Wed Nov 07 00:10:08.778917 2018] [:error] [pid 29564] avahi_entry_group_add_service_strlst(“openemrhost”) failed: Local name collision
[Wed Nov 07 07:54:11.108058 2018] [:error] [pid 29569] [client 192.168.11.27:58396] PHP Fatal error: Uncaught Error: Call to undefined function mysqli_query() in /var/www/openemr/vendor/adodb/adodb-php/drivers/adodb-mysqli.inc.php:786\nStack trace:\n#0 /var/www/openemr/vendor/adodb/adodb-php/adodb.inc.php(1251): ADODB_mysqli->_query(‘SET NAMES ‘utf8…’, false)\n#1 /var/www/openemr/vendor/adodb/adodb-php/adodb.inc.php(1229): ADOConnection->_Execute(‘SET NAMES ‘utf8…’, false)\n#2 /var/www/openemr/library/ADODB_mysqli_log.php(24): ADOConnection->Execute(‘SET NAMES ‘utf8…’, false)\n#3 /var/www/openemr/library/sql.inc(53): ADODB_mysqli_log->Execute(‘SET NAMES ‘utf8…’)\n#4 /var/www/openemr/interface/globals.php(268): require_once(’/var/www/openem…’)\n#5 /var/www/openemr/interface/login/login.php(33): require_once(’/var/www/openem…’)\n#6 {main}\n thrown in /var/www/openemr/vendor/adodb/adodb-php/drivers/adodb-mysqli.inc.php on line 786

(Not able log on to OpenEMR as of that morning)

From what I can see, things are more or less the same with some minor differences in format after the upgrade; the highlighted error seems to be the key difference that matches up with when we could no longer log on.

Does this reveal the problem?

-Venu


(Dan E) #8

Are you sure this isn’t a security issue?

I’m not as familiar with the code base as other people, but what it looks like is someone is trying to turn off UTF8 to get the server to accept a wider variety of characters (e.g. Chinese characters).

Here is a link that sort of goes into detail on this vulnerability: https://stackoverflow.com/questions/5139127/php-sql-injection-utf8-poc

How is the server secured?


(Jerry P) #9

@dan_openemr It turns UTF8 encoding on by default. @vrjula I don’t see anything glaring from your logs. Maybe check your mysql logs. Also, for grins maybe try turning off the setting of UTF8 encoding and see how far we get. You do this by editing you sites/default/sqlconf .php and change line $disable_utf8_flag = false; to $disable_utf8_flag = true;
Also, do you know the version of Maria or Mysql though, it is strange to just stop working within a restart.


(Brady Miller) #10

Hi @vrjula ,
I think that error usually happens when the connection to mysql/mariadb isn’t working. Are you seeing the login screen?
-brady


(Venu Julapalli) #11

@sjpadgett, here is my mysql log when I restart mysql:

2018-11-09T03:10:42.447562Z 0 [Note] Giving 0 client threads a chance to die gracefully
2018-11-09T03:10:42.447658Z 0 [Note] Shutting down slave threads
2018-11-09T03:10:42.447682Z 0 [Note] Forcefully disconnecting 0 remaining clients
2018-11-09T03:10:42.447703Z 0 [Note] Event Scheduler: Purging the queue. 0 events
2018-11-09T03:10:42.447812Z 0 [Note] Binlog end
2018-11-09T03:10:42.448689Z 0 [Note] Shutting down plugin ‘ngram’
2018-11-09T03:10:42.448732Z 0 [Note] Shutting down plugin ‘partition’
2018-11-09T03:10:42.448739Z 0 [Note] Shutting down plugin ‘BLACKHOLE’
2018-11-09T03:10:42.448746Z 0 [Note] Shutting down plugin ‘ARCHIVE’
2018-11-09T03:10:42.448751Z 0 [Note] Shutting down plugin ‘PERFORMANCE_SCHEMA’
2018-11-09T03:10:42.448808Z 0 [Note] Shutting down plugin ‘MRG_MYISAM’
2018-11-09T03:10:42.448815Z 0 [Note] Shutting down plugin ‘MyISAM’
2018-11-09T03:10:42.448825Z 0 [Note] Shutting down plugin ‘INNODB_SYS_VIRTUAL’
2018-11-09T03:10:42.448831Z 0 [Note] Shutting down plugin ‘INNODB_SYS_DATAFILES’
2018-11-09T03:10:42.448836Z 0 [Note] Shutting down plugin ‘INNODB_SYS_TABLESPACES’
2018-11-09T03:10:42.448842Z 0 [Note] Shutting down plugin ‘INNODB_SYS_FOREIGN_COLS’
2018-11-09T03:10:42.448847Z 0 [Note] Shutting down plugin ‘INNODB_SYS_FOREIGN’
2018-11-09T03:10:42.448852Z 0 [Note] Shutting down plugin ‘INNODB_SYS_FIELDS’
2018-11-09T03:10:42.448879Z 0 [Note] Shutting down plugin ‘INNODB_SYS_COLUMNS’
2018-11-09T03:10:42.448884Z 0 [Note] Shutting down plugin ‘INNODB_SYS_INDEXES’
2018-11-09T03:10:42.448889Z 0 [Note] Shutting down plugin ‘INNODB_SYS_TABLESTATS’
2018-11-09T03:10:42.448894Z 0 [Note] Shutting down plugin ‘INNODB_SYS_TABLES’
2018-11-09T03:10:42.448899Z 0 [Note] Shutting down plugin ‘INNODB_FT_INDEX_TABLE’
2018-11-09T03:10:42.448904Z 0 [Note] Shutting down plugin ‘INNODB_FT_INDEX_CACHE’
2018-11-09T03:10:42.448908Z 0 [Note] Shutting down plugin ‘INNODB_FT_CONFIG’
2018-11-09T03:10:42.448913Z 0 [Note] Shutting down plugin ‘INNODB_FT_BEING_DELETED’
2018-11-09T03:10:42.448918Z 0 [Note] Shutting down plugin ‘INNODB_FT_DELETED’
2018-11-09T03:10:42.448922Z 0 [Note] Shutting down plugin ‘INNODB_FT_DEFAULT_STOPWORD’
2018-11-09T03:10:42.448927Z 0 [Note] Shutting down plugin ‘INNODB_METRICS’
2018-11-09T03:10:42.448932Z 0 [Note] Shutting down plugin ‘INNODB_TEMP_TABLE_INFO’
2018-11-09T03:10:42.448936Z 0 [Note] Shutting down plugin ‘INNODB_BUFFER_POOL_STATS’
2018-11-09T03:10:42.448941Z 0 [Note] Shutting down plugin ‘INNODB_BUFFER_PAGE_LRU’
2018-11-09T03:10:42.448946Z 0 [Note] Shutting down plugin ‘INNODB_BUFFER_PAGE’
2018-11-09T03:10:42.448950Z 0 [Note] Shutting down plugin ‘INNODB_CMP_PER_INDEX_RESET’
2018-11-09T03:10:42.448955Z 0 [Note] Shutting down plugin ‘INNODB_CMP_PER_INDEX’
2018-11-09T03:10:42.448960Z 0 [Note] Shutting down plugin ‘INNODB_CMPMEM_RESET’
2018-11-09T03:10:42.448965Z 0 [Note] Shutting down plugin ‘INNODB_CMPMEM’
2018-11-09T03:10:42.448969Z 0 [Note] Shutting down plugin ‘INNODB_CMP_RESET’
2018-11-09T03:10:42.448974Z 0 [Note] Shutting down plugin ‘INNODB_CMP’
2018-11-09T03:10:42.448979Z 0 [Note] Shutting down plugin ‘INNODB_LOCK_WAITS’
2018-11-09T03:10:42.448984Z 0 [Note] Shutting down plugin ‘INNODB_LOCKS’
2018-11-09T03:10:42.448989Z 0 [Note] Shutting down plugin ‘INNODB_TRX’
2018-11-09T03:10:42.448993Z 0 [Note] Shutting down plugin ‘InnoDB’
2018-11-09T03:10:42.449079Z 0 [Note] InnoDB: FTS optimize thread exiting.
2018-11-09T03:10:42.449270Z 0 [Note] InnoDB: Starting shutdown…
2018-11-09T03:10:42.549645Z 0 [Note] InnoDB: Dumping buffer pool(s) to /var/lib/mysql/ib_buffer_pool
2018-11-09T03:10:42.550386Z 0 [Note] InnoDB: Buffer pool(s) dump completed at 181108 21:10:42
2018-11-09T03:10:43.929907Z 0 [Note] InnoDB: Shutdown completed; log sequence number 4475459551
2018-11-09T03:10:43.931641Z 0 [Note] InnoDB: Removed temporary tablespace data file: “ibtmp1”
2018-11-09T03:10:43.931671Z 0 [Note] Shutting down plugin ‘MEMORY’
2018-11-09T03:10:43.931677Z 0 [Note] Shutting down plugin ‘CSV’
2018-11-09T03:10:43.931682Z 0 [Note] Shutting down plugin ‘sha256_password’
2018-11-09T03:10:43.931685Z 0 [Note] Shutting down plugin ‘mysql_native_password’
2018-11-09T03:10:43.931831Z 0 [Note] Shutting down plugin ‘binlog’
2018-11-09T03:10:43.932175Z 0 [Note] /usr/sbin/mysqld: Shutdown complete

2018-11-09T03:10:44.251234Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2018-11-09T03:10:44.253250Z 0 [Note] /usr/sbin/mysqld (mysqld 5.7.24-0ubuntu0.18.04.1) starting as process 16066 …
2018-11-09T03:10:44.258608Z 0 [Note] InnoDB: PUNCH HOLE support available
2018-11-09T03:10:44.258645Z 0 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2018-11-09T03:10:44.258651Z 0 [Note] InnoDB: Uses event mutexes
2018-11-09T03:10:44.258655Z 0 [Note] InnoDB: GCC builtin __atomic_thread_fence() is used for memory barrier
2018-11-09T03:10:44.258659Z 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
2018-11-09T03:10:44.258664Z 0 [Note] InnoDB: Using Linux native AIO
2018-11-09T03:10:44.258945Z 0 [Note] InnoDB: Number of pools: 1
2018-11-09T03:10:44.259066Z 0 [Note] InnoDB: Not using CPU crc32 instructions
2018-11-09T03:10:44.260910Z 0 [Note] InnoDB: Initializing buffer pool, total size = 128M, instances = 1, chunk size = 128M
2018-11-09T03:10:44.272871Z 0 [Note] InnoDB: Completed initialization of buffer pool
2018-11-09T03:10:44.275446Z 0 [Note] InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority().
2018-11-09T03:10:44.289047Z 0 [Note] InnoDB: Highest supported file format is Barracuda.
2018-11-09T03:10:44.347126Z 0 [Note] InnoDB: Creating shared tablespace for temporary tables
2018-11-09T03:10:44.347223Z 0 [Note] InnoDB: Setting file ‘./ibtmp1’ size to 12 MB. Physically writing the file full; Please wait …
2018-11-09T03:10:44.524242Z 0 [Note] InnoDB: File ‘./ibtmp1’ size is now 12 MB.
2018-11-09T03:10:44.527299Z 0 [Note] InnoDB: 96 redo rollback segment(s) found. 96 redo rollback segment(s) are active.
2018-11-09T03:10:44.527355Z 0 [Note] InnoDB: 32 non-redo rollback segment(s) are active.
2018-11-09T03:10:44.528441Z 0 [Note] InnoDB: Waiting for purge to start
2018-11-09T03:10:44.578826Z 0 [Note] InnoDB: 5.7.24 started; log sequence number 4475459551
2018-11-09T03:10:44.579341Z 0 [Note] InnoDB: Loading buffer pool(s) from /var/lib/mysql/ib_buffer_pool
2018-11-09T03:10:44.579859Z 0 [Note] Plugin ‘FEDERATED’ is disabled.
2018-11-09T03:10:44.591252Z 0 [Warning] Failed to set up SSL because of the following SSL library error: SSL context is not usable without certificate and private key
2018-11-09T03:10:44.591281Z 0 [Note] Server hostname (bind-address): ‘127.0.0.1’; port: 3306
2018-11-09T03:10:44.591292Z 0 [Note] - ‘127.0.0.1’ resolves to ‘127.0.0.1’;
2018-11-09T03:10:44.591335Z 0 [Note] Server socket created on IP: ‘127.0.0.1’.
2018-11-09T03:10:44.592001Z 0 [Note] InnoDB: Buffer pool(s) load completed at 181108 21:10:44
2018-11-09T03:10:44.598707Z 0 [Note] Event Scheduler: Loaded 0 events
2018-11-09T03:10:44.599216Z 0 [Note] /usr/sbin/mysqld: ready for connections.
Version: ‘5.7.24-0ubuntu0.18.04.1’ socket: ‘/var/run/mysqld/mysqld.sock’ port: 3306 (Ubuntu)

I turned off UTF8 encoding as you suggested and restarted apache2 and mysql, but I got the same error.

I have mysql Ver 14.14 Distrib 5.7.24, for Linux (x86_64) using EditLine wrapper

@brady.miller, I’m not seeing the login screen. I just get a completely blank page.

-Venu


(Jerry P) #12

I have to agree with Brady because it looks like you’re not connecting.After getting the error logging into openemr does mysql logs show a decline or anything having to do with connecting? Logs show starting okay to me. Have you tried logging into mysql via terminal with your credentials from sqlconf.php i.e mysql -u user -ppassword database ?


(Venu Julapalli) #13

I’m not seeing any errors in the mysql log when I attempt to log in. I am able to log in to mysql from the command line.

-Venu


(Jerry P) #14

This has got to be frustrating for you. Lets check you privileges.

  • Log in mysql from command line then run query:
select User,host,plugin from mysql.user;

Check the plugin value returned. Is it auth_socket or mysql_native_password. This is important and sometimes on new install isn’t set right.


(Venu Julapalli) #15

Yes, frustrating, to say the least. I need to get this back up by Monday.

The plugin value for all users is mysql_native_password.


(Jerry P) #16

Can you private messaging or send me a link so I can try logging on and do a look see using firefox debugger?


(Venu Julapalli) #17

Great, we can take this offline. Please email me at vrjula@protonmail.com.

Thanks,
Venu


(Jerry P) #18

Hi @vrjula, I know we look to see if mysqli extension was loaded but can you just verify again with

php -m | grep mysqli

to be sure. However i’m thinking the wrong version is being loaded i.e your old php version may be interfering with upgraded version. You might want to purge old php5 if still on system.


(Venu Julapalli) #19

With that command, I still see the mysqli extension. And I don’t have php5 on the system, as far as I can tell.

I replaced the vendor folder; the vendor folder has some php5 related files in symfony, but that’s about it. Replacing the vendor folder has not solved the problem.

–Venu


(Jerry P) #20

Okay, but I still think something is up with the existing mysqli extension. Maybe try re install the extension. As soon as I finish installing HIE on a site for a friend i’ll e-mail or call and we can take it up again.
Meanwhile maybe one of our friends in the community has encountered this issue after an upgrade to 18.04 and PHP 7.2.
System returns the same error and call stack of mysqli_query() doesn’t exist when you disable the mysqli extension in php.ini as it is doing currently on your system. So, though it shows it is loaded, ado driver doesn’t think so!