Read about OpenEMR's Response to the COVID-19 Pandemic at https://www.open-emr.org/covid19/

Patient Portal patient documents page fatal error

Every time I use the patient portal Patient Documents page I get a fatal error. Here is the error data. Not sure why the error persists after doing a fresh install when the prior one was working.

Fatal Error:
Trying to access array offset on value of type bool in translation.inc.php at line 44
Original Stack Trace:
#0 /var/www/html/emr/library/translation.inc.php(44): ExceptionThrower::HandleError()
#1 /var/www/html/emr/library/htmlspecialchars.inc.php(138): xl()
#2 /var/www/html/emr/library/htmlspecialchars.inc.php(158): hsc_private_xl_or_warn()
#3 /var/www/html/emr/portal/patient/templates/OnsiteDocumentListView.tpl.php(28): xlt()
#4 /var/www/html/emr/portal/patient/fwk/libs/savant/Savant3.php(1022): include(’/var/www/html/e…’)
#5 /var/www/html/emr/portal/patient/fwk/libs/savant/Savant3.php(958): Savant3->fetch()
#6 /var/www/html/emr/portal/patient/fwk/libs/savant/Savant3.php(944): Savant3->getOutput()
#7 /var/www/html/emr/portal/patient/fwk/libs/verysimple/Phreeze/SavantRenderEngine.php(69): Savant3->display()
#8 /var/www/html/emr/portal/patient/fwk/libs/verysimple/Phreeze/Controller.php(850): SavantRenderEngine->display()
#9 /var/www/html/emr/portal/patient/libs/Controller/OnsiteDocumentController.php(87): Controller->Render()
#10 /var/www/html/emr/portal/patient/fwk/libs/verysimple/Phreeze/Dispatcher.php(169): OnsiteDocumentController->ListView()
#11 /var/www/html/emr/portal/patient/index.php(31): Dispatcher::Dispatch()
#12 {main}
In addition to the above error, the default error template could not be displayed:
Trying to access array offset on value of type bool in translation.inc.php at line 44

#0 /var/www/html/emr/library/translation.inc.php(44): ExceptionThrower::HandleError()
#1 /var/www/html/emr/library/htmlspecialchars.inc.php(138): xl()
#2 /var/www/html/emr/library/htmlspecialchars.inc.php(158): hsc_private_xl_or_warn()
#3 /var/www/html/emr/portal/patient/templates/DefaultErrorFatal.tpl.php(9): xlt()
#4 /var/www/html/emr/portal/patient/fwk/libs/savant/Savant3.php(1022): include(’/var/www/html/e…’)
#5 /var/www/html/emr/portal/patient/fwk/libs/savant/Savant3.php(958): Savant3->fetch()
#6 /var/www/html/emr/portal/patient/fwk/libs/savant/Savant3.php(944): Savant3->getOutput()
#7 /var/www/html/emr/portal/patient/fwk/libs/verysimple/Phreeze/SavantRenderEngine.php(69): Savant3->display()
#8 /var/www/html/emr/portal/patient/index.php(55): SavantRenderEngine->display()
#9 {main}

If you have seen this and know a fix before I start digging into the files later this week it would be much appreciated

@Jeremiah_Ocasio were you able to fix this issue?

I just found this yesterday @juggernautsei @juggernautsei!

It’s caused by incompatibility wit PHP 7.4.
P.R onsite portal PHP 7.4 update by sjpadgett · Pull Request #3587 · openemr/openemr · GitHub
and a quick patch to fix:
Loss of convenient features

Good Luck

1 Like

@juggernautsei Just getting back to this after fixing some production issues for our other systems. Ill update here after I get it corrected. @sjpadgett Thanks Jerry! Ill run through that solution and confirm back if it solved mine here too.