Patient Portal not communicating with OpenEMR


(system) #1

davidjernigan3 wrote on Wednesday, July 22, 2015:

I welcome help/ideas for getting our patient portal to work.
Problem: We are not seeing any requests from the Wordpress site in OpenEMR.
-Data is collected and available on the Wordpress site, but OpenEMR is not communicating with the Wordpress site.
-Our Wordpress site is hosted offsite by a third party.
-Site was set up and configured as per the CMS Portal Documentation (to the best of my knowledge)
-Ninja forms have been downloaded and installed from Sunset. (Field names match with OpenEMR)
-The latest Sunset Patient Portal plugin has been installed and activated.
-The OpenEMR user on the Wordpress site is active. I can log in as an admin with the credentials. -The additional capability manage_portal has been added.
-Verified php5-cURL is installed
-Reviewed the CMS Patient Portal demo to compare settings; all looks ok.
It certainly seems as if the CMS Portal setup in OpenEMR (Administration-> Globals-> Portal) is incorrect, but different login credentials have been tried.
Should the CMS Portal Site Address be:
https://www.site_name.com/wp-login.php, or
https://www.site_name.com
I have tried both.
Open to any suggestions. Thanks.
David


(system) #2

fsgl wrote on Thursday, July 23, 2015:

Did you try http://your site name/wordpress? See 1.

Assume that correct username & password had been entered in Globals/Portal.

It does not appear that clicking “CMS Portal” in the Menu takes one to the Wordpress site. See 2.


(system) #3

sunsetsystems wrote on Thursday, July 23, 2015:

The URL would be for the directory of the WordPress site. In your example, looks like it would be “https://www.site_name.com/” (with or without the trailing slash should be OK). The code appends “/wp-content/plugins/sunset-patient-portal/webserve.php” to this to get the path to the needed script, so make sure that is in the indicated place.

First step is to check the web server’s error log for any relevant errors. If there are none and you know PHP, you could start adding debug code into interface/cmsportal/portal.inc.php to find out what’s going on.

Otherwise you may need some programming help. Ninja Forms has changed their database structure around from one release to the next, and they might have done something to break the portal.

Rod
http://www.sunsetsystems.com/


(system) #4

sunsetsystems wrote on Thursday, July 23, 2015:

Oh and don’t use a self-signed SSL certificate. The cURL library wants a commercial certificate. If you have that problem you should see an error logged for it.

Rod
http://www.sunsetsystems.com/


(system) #5

davidjernigan3 wrote on Thursday, July 23, 2015:

Thanks very much fsgl and Rod! Will start there.
I appreciate your help.


(system) #6

davidjernigan3 wrote on Thursday, July 23, 2015:

The error I am getting is:

ModSecurity: Access denied with code 406 (phase 1). Pattern match “^POST$” at REQUEST_METHOD. [file “/etc/httpd/modsecurity.d/eig_rules.conf”] [line “80”] [id “900185”] [msg “UA Spam POST http 1.1 :: Steelrat”] [hostname “www.skinsurgeryportal.com”] [uri “/wp-content/plugins/sunset-patient-portal/webserve.php”]

  1. Does this mean modsecurity believes the request is an attack? If so, is this an issue I need to work through Wordpress or my web hosting service?
  2. Is it possible the issue is the IP address from the originating request?

Your help is much appreciated.


(system) #7

sunsetsystems wrote on Friday, July 24, 2015:

It sounds like a false positive. I’m not a big fan of mod_security. See if the hosting service will disable or fix it.

Rod
http://www.sunsetsystems.com/


(system) #8

davidjernigan3 wrote on Friday, July 24, 2015:

Thanks. I am trying to get something done with them now.


(system) #9

davidjernigan3 wrote on Tuesday, July 28, 2015:

Thanks very much. It was whitelisted and the portal works great now.
The portal is a really nice feature to OpenEMR and the software works really well. It is convenient and well-thought out. Thanks for the portal and your help, Rod.


(system) #10

sunsetsystems wrote on Tuesday, July 28, 2015:

David, thanks for the kind words. When you get to a suitable point it would be cool to publish some screen shots as I think others will be interested in what finished portal sites look like.

Rod
http://www.sunsetsystems.com/


How to connect wordpress with openemr
(gaffer) #11

Hello guys,

firstly, many thanks for these solutions and plugins. I have followed the wiki religiously and setup accordignly. However, I’m running into problems with communication between Worpress & the CMS portal on OpenEMR.

I checked the error log in sunset portal and it says;

[19-May-2017 11:01:12 UTC] WordPress database error Table 'TEST_wp.wpfs_nf_objectmeta' doesn't exist for query SELECT p.ID, p.post_date, u.user_login, om.meta_value AS form_title FROM wpfs_posts AS p JOIN wpfs_postmeta AS pm ON pm.post_id = p.ID AND pm.meta_key = '_form_id' JOIN wpfs_nf_objectmeta AS om ON om.object_id = pm.meta_value AND om.meta_key = 'form_title' LEFT JOIN wpfs_users AS u ON u.ID = p.post_author WHERE p.post_type = 'nf_sub' ORDER BY p.post_date made by action_list

Could you please help me in deciphering what is going on here?

NB: I replaced database name with “TEST” in the error above for security reasons.

Many thanks in advance.


(Seth) #12

Hello, I am having trouble getting my Wordpress Portal to communicate with OpenEMR. I followed your instructions and using the file path:
https://www.site_name.com/wp-content/plugins/sunset-patient-portal/webserve.php
My browser downloaded a file titled, “cmsreply.bin” which displays the following error:

a:1:{s:6:“errmsg”;s:29:“Portal authentication failed.”;}

I tried editing the CMS Portal address located within Administration > Global Settings > Portal by entering https and just http. Perhaps the error I am having is that the SSL certificate I purchased is on my active domain, and I am building this wordpress site on a temporary domain while its under development.