Patient Portal 2 Dashboard - TPL Size


(Erik Pampalone) #1

Hi @sjpadgett,

Do you know how I can think about the following?

I created a new template in the Portal Dashboard.

I am able to sign the document as a patient and send it for review.

When I review the document I can see the first three pages only, and the portal indicates the document is not signed.

Any ideas on what is happening and how I can approach fixing it?

(Jerry P) #2

What Patch level are you at? Pretty sure one of our Patches fixed if it is a long form. The fix was for a form longer than… shoot I forgot :slight_smile: Anyway it was increased to a form up to 16K. The patch also fix a signature problem.

(Erik Pampalone) #3

Great news @sjpadgett! The update worked. The portal now appears to sign everything correctly.

Bad news is, after the update I get a blank site.

Any suggestions troubleshooting this?

Log files are minimal.

[Fri Mar 15 22:50:33.985498 2019] [php7:notice] [pid 1944] [client] PHP 
Notice:  Undefined index: basePath in /var/www/openemr/library/core/src/Header.php on line 158
[Fri Mar 15 22:50:37.558874 2019] [php7:notice] [pid 1944] [client] PHP 
Notice:  Undefined index: basePath in /var/www/openemr/library/core/src/Header.php on line 158, 
referer: https://<


(Jerry P) #4

Any browser console errors? I will check my 501 to see if patch 7 if not i’ll install. Check your console while logging in…

(Erik Pampalone) #5

Here’s what I see on login.

(Jerry P) #6

hmm, I know kinda what is going on but can’t understand how we got here. What patch level where you on when Patch(7) was applied?

also, turn off portal to see if site comes back…

(Brady Miller) #7

One quick thing to try is to clear the cookies/cache on your browser.

(Jerry P) #8

Most likely the issue 'cause works for me but a concern…

(Jerry P) #9

Got this wrong and want to clarify for others whom happen unto this thread.
Previously form templates could be upto 65K but with patch new size limit is 16M. I’d like to see that template. :slight_smile:

(Erik Pampalone) #10

Clearing the cache did it. I was fooled because I tried it on two browsers and got the same problem. Once you said to clear the cache, I tried it on a third browser and it worked.

I can send you the template. Is there a way to download the template from the site? Or can you tell me where it is on the file system?