Do you use or administer OpenEMR? Take the General Satisfaction Survey to help improve the product

Patient finder function Error

Situation
Describe your problem here After installing the 6.0. patch and setting up a record for myself through patient portal I tried to play with message, chat options on the patient portal. After that in the provider portal when using “Patient finder” menu I get the following Error:

Uncaught TypeError: msg. to LowerCase is not a function
URL: https://localhost/openemr/library/js/utility.js?v=61
Line 453 Column 26
Error object “[]””

The Patient finder does not work

OpenEMR Version
I’m using OpenEMR version 6.0.0

Browser:
I’m using: Microsoft edge, Google chrome

Operating System
I’m using: Linux Ubuntu

Logs
Did you check the logs? Yes
Was there anything pertinent in them? Yes

Please paste them here:

—Query pnotes.id, pnotes.user, pnotes.pid, pnotes.title, pnotes.date, pnotes.message_status, pnotes.activity,
IF(pnotes.pid = 0 OR pnotes.user != pnotes.pid,users.fname,patient_data.fname) as users_fname,
IF(pnotes.pid = 0 OR pnotes.user != pnotes.pid,users.lname,patient_data.lname) as users_lname,
patient_data.fname as patient_data_fname, patient_data.lname as patient_data_lname
FROM ((pnotes LEFT JOIN users ON pnotes.user = users.username)
LEFT JOIN patient_data ON pnotes.pid = patient_data.pid) WHERE pnotes.message_status != ‘Done’ AND pnotes.activity = 1 AND
pnotes.deleted != ‘1’ AND pnotes.assigned_to LIKE ? (‘ViktorVHinov’,)—

I don’t understand! what picker, where? check punctuation in name, maybe wasn’t escaped properly on save.
error comes from debugger so try turning off.

Thank you so much for your help! I really appreciate it!
Just tried turning debugger off. When try to save system returns Authentication error message

I still don’t know where you encounter error! In portal dashboard, demographics where? how about a screenshot.
We have patient picker in many places…

again turn off user debug, log out then back in. also need to see what browser console shows the actual error is.

This is the result when I try to turn the user debugging off:

Here is what the Console is saying:

View issues
utility.js?v=61:86 Needed to load:[/openemr/public/assets/interactjs/dist/interact.js] For: [https://drhinov.com/openemr/interface/main/messages/messages.php?form_active=1]
utility.js?v=61:447 User Debug Error Catch
Object
utility.js?v=61:453 Uncaught TypeError: msg.toLowerCase is not a function
at HTMLBodyElement.window.onerror (utility.js:453)
at Object.trigger (jquery.min.js:2)
at HTMLTableElement. (jquery.min.js:2)
at Function.each (jquery.min.js:2)
at S.fn.init.each (jquery.min.js:2)
at S.fn.init.trigger (jquery.min.js:2)
at t (jquery.dataTables.min.js:76)
at K (jquery.dataTables.min.js:75)
at Object.error (jquery.dataTables.min.js:36)
at c (jquery.min.js:2)


shouldn’t be getting that with debug turned off. plus the Authenticate error is due to a CSRF error but could be caused by javascript error.
Clear browser cache to ensure utility.js is not in scope.
A new patient add shouldn’t have anything to do with this error but you could delete new patient to see but, after clearing cache

Thank you so much Jerry
I was able to fix it. It was probably not OpenEMR problem since everything works fine on my server and only gives troubles on out of network PC.
By the way do you know if the Email notifications are working under 6.0.0 version or you would recommend to use outside E-mail to send portal invites to patients still?

You’re welcome. The CSRF error was a good indication of access problem.
Notifications work the best I can tell. I use google but any SMTP should work.
Not sure what others use and maybe some of them will chime in here.