OpenEMR was installed successfully with many Notices and Warnings on Windowscrashed 10


(richey lee) #1

Situation
After I logged on, the UI of OpenEMR is not correct - the Main Menu is displayed the lower part of the screen, and there are some missing, errors, warnings above the Main Menu. The worse is that after I logged out and restarted, MySQL crashed …

OpenEMR Version
I’m using OpenEMR version 5.0.1

Browser:
I’m using: Chrome

Operating System
I’m using: Win 10

Logs
Did you check the logs? Was there anything pertinent in them? Paste them here (surround with three backticks (```) for readability

2019-07-17 19:47:29 0 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2019-07-17 19:47:29 0 [Note] InnoDB: Uses event mutexes
2019-07-17 19:47:29 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
2019-07-17 19:47:29 0 [Note] InnoDB: Number of pools: 1
2019-07-17 19:47:29 0 [Note] InnoDB: Using SSE2 crc32 instructions
2019-07-17 19:47:29 0 [Note] InnoDB: Initializing buffer pool, total size = 16M, instances = 1, chunk size = 16M
2019-07-17 19:47:29 0 [Note] InnoDB: Completed initialization of buffer pool
2019-07-17 19:47:29 0 [Note] InnoDB: Starting crash recovery from checkpoint LSN=1791378
2019-07-17 19:47:29 0 [Note] InnoDB: 128 out of 128 rollback segments are active.
2019-07-17 19:47:29 0 [Note] InnoDB: Removed temporary tablespace data file: “ibtmp1”
2019-07-17 19:47:29 0 [Note] InnoDB: Creating shared tablespace for temporary tables
2019-07-17 19:47:29 0 [Note] InnoDB: Setting file ‘C:\xampp\mysql\data\ibtmp1’ size to 12 MB. Physically writing the file full; Please wait …
2019-07-17 19:47:29 0 [Note] InnoDB: File ‘C:\xampp\mysql\data\ibtmp1’ size is now 12 MB.
2019-07-17 19:47:29 0 [Note] InnoDB: Waiting for purge to start
2019-07-17 19:47:29 0 [Note] InnoDB: 10.3.16 started; log sequence number 1791387; transaction id 163
2019-07-17 19:47:29 0 [Note] InnoDB: Loading buffer pool(s) from C:\xampp\mysql\data\ib_buffer_pool
2019-07-17 19:47:29 0 [Note] InnoDB: Buffer pool(s) load completed at 190717 19:47:29
2019-07-17 19:47:29 0 [Note] Plugin ‘FEEDBACK’ is disabled.
2019-07-17 19:47:29 0 [Note] Server socket created on IP: ‘::’.
2019-07-17 20:47:50 0 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2019-07-17 20:47:50 0 [Note] InnoDB: Uses event mutexes
2019-07-17 20:47:50 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
2019-07-17 20:47:50 0 [Note] InnoDB: Number of pools: 1

Xampp Control Panel:

10:19:53 PM [mysql] Status change detected: stopped
10:19:53 PM [mysql] Error: MySQL shutdown unexpectedly.
10:19:53 PM [mysql] This may be due to a blocked port, missing dependencies,
10:19:53 PM [mysql] improper privileges, a crash, or a shutdown by another method.
10:19:53 PM [mysql] Press the Logs button to view error logs and check
10:19:53 PM [mysql] the Windows Event Viewer for more clues
10:19:53 PM [mysql] If you need more help, copy and post this
10:19:53 PM [mysql] entire log window on the forums

Mutexes and rw_locks use Windows interlocked functions


(Sherwin Gaddis) #2

Can you give more details as to what steps you took to install the program?
Did you follow these instructions

https://www.open-emr.org/wiki/index.php/OpenEMR_5.0.1_Windows_Installation

(richey lee) #3

Hi Sherwin,

Yes, I followed the instructions. The only thing I have not done is to install the patches.

Currently I can use MySQL Workbench to do the SQL job which means the MySQL database works well. Below is the logon webpage for your reference. Please help and advise.

Thanks,

Richey


(Sherwin Gaddis) #4

In your PHP file turn off display errors.

https://www.open-emr.org/wiki/index.php/FAQ

What are the correct PHP settings (can be found in the php.ini file)?

We recommend the following PHP setting, which can be set in the php.ini file (If you do modify this file, remember to restart your web server (usually Apache) to apply the new settings):

short_open_tag = Off

max_execution_time = 60

max_input_time = -1

max_input_vars = 3000

memory_limit = 512M

display_errors = Off

log_errors = On

post_max_size = 30M

file_uploads = On

upload_max_filesize = 30M

error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT

mysqli.allow_local_infile = On


(richey lee) #5

Hi Sherwin,

Thank you for your help. I followed your recommendation and the OpenEMR works now. Actually I followed the online instructions and it did not work. Anyway, now the main issue is that I cannot I can out find out where the Database function
is as it is supposed being under the path Adminstration
àOthere àDatabase.

Best,

Rchey


(Sherwin Gaddis) #6

For OpenEMR versions 5.0.1 and above

phpMyAdmin was removed . See this forum thread for details: Removing phpMyAdmin


(richey lee) #7

Thanks! So what is your recommendation to use the database without the function.

Thanks

Richey


(Sherwin Gaddis) #8

If I am understanding your question correctly, use the phpmyadmin in xampp.

Click the admin link next to MySQL

image


(richey lee) #9

Thank you!

Yes, I also meant the functions to view the database structure, impart/export data etc although they could be done by MySQL Workbench. Am I right?

Again, I have the problem to restart OpenEMR which means only the first time it worked after the installation. Below is the screenshot of the current problem. There was also a time Tomcat failed running. Please advise.

Best,

Richey


(Sherwin Gaddis) #10

Yes, you are free to use any tool to access the database. You don’t need Tomcat. You can uncheck that box. Try starting after disabling Tomcat.