OpenEMR V7 - NewCrop e-prescribe broken

There appears to be a bug in the eRX code in V7, I was hoping it might be fixed in Patch 2, but it’s not.
When you open a patient, and try to access NewCrop either with the button or the top menu option for e-Rx, the system responds with the error “The following fields have to be filled to send a request. * NewCrop eRx Password”
All the NewCrop eRx parameters are populated in globals, and I verified by manually checking in the database fields to confirm that all the required strings are stored under the correct variable names.
Surely this has come up before?
Platform is Ubuntu 20 LTS, with MariaDB 10.5, have tried using PHP 7.4, 8.0, and 8.1, all with the same error.
I am also getting the dreaded “OpenEMR Error : Decryption is not working because of unknown encrypt/decrypt version.” over and over in the error logs, and it’s always there right before the NewCrop transaction fails, so could be related.

This is difficult to troubleshoot because of setting up account e.t.c.
@htuck Anything to say? Have you noticed issue with your clients?
@Jit_Chawla How about you. I know you are using but not sure which openemr version.

Hi @Penguin8R -
OpenEMR V7 has no bug in its eRx code. That password field is one of the login credentials that is passed from OpenEMR to NewCrop in the handshake that occurs when a user attempts to open a particular patient’s NewCrop record.

I assume that your OpenEMR had previously done NewCrop without problems then you upgraded to v7 and it started throwing that error? All I can think is that the password must have gotten corrupted somehow in the upgrade . Your NewCrop vendor can replace the password for you.

If you do not have a NewCrop vendor you will need to sign up with one in order to access NewCrop. And as it happens I work for MI-Squared which I heard gossip last week saying we are the only remaining vendors of NewCrop for OpenEMR. You’re welcome to DM me from here if you want to ask about signing with us. My apologies if I heard wrong, I’m not trying to hustle business here on the forum.

Sorry, I cannot advise on your dreaded encryption error.
Good luck- Harley

1 Like

Thanks @htuck for they help…

Yer welcome @sjpadgett , I’m always happy to contribute to the edumacation of the OpenEMR community!

@htuck where are the eRX logs accessible from in V7? Thanks

@Jit_Chawla when i enable newcrop on my sandbox v7 server the erx logs are under:
Admin->Other->eRx Logs.

You might have to log out and then back in for it to show up.

Thanks but don’t see it.

@Jit_Chawla do you have logging turned on in the newcrop setting?

@Jit_Chawla i could be wrong but if you got to Admin->Global->Connectors then go down to “NewCrop eRx Debug Settings” and change that to something other then “none” it might get you that menu item. Also of course you’ll have to log out and back in for the changes to make a difference.

edit: Also by looking at your screen shot. It doesn’t look like you have Newcrop enabled. You should have a newcrop menu in the top menu bar if it is enabled.

If you do have it enabled and the newcrop menu isn’t there, double check that you aren’t using a “custom” menu for the user you are logged in as.

Hi @Jit_Chawla
The thing about NewCrop is, it’s a proprietary service which must be subscribed to through an approved NewCrop vendor in order to connect to it. The vendor enters their NewCrop account credentials into the OpenEMR connectors and it is those credentials which trigger the display of the ‘eRx Logs’ item in the Admin menu


As it happens, we at MI-Squared are currently the only approved NewCrop vendor for OpenEMR. If you’d like to explore signing up for one of our eRx subscriptions please DM me and I’d be happy to discuss it.
Best- Harley

Not sure how to send DM here but I will email you and please respond ASAP. Note that the Client has engaged New Crop already and they told to do a contract with them. Let’s get clarity on how that happens when we engage on email.

Hi @Jit_Chawla I see the email, thx.
For future reference, DM by clicking on the icon (round rectangle) of the person you want to message, and a popup appears with a ‘message’ button on it.
Best- HT
Screenshot at 2023-03-14 11-07-12