OpenEMR and MirthConnect on Windows 10


I am trying to create a development environment on my Windows desktop that includes OpenEMR and MirthConnect.

I am using XAMPP for Windows 7.3.8. The control panel version is 3.2.4.

The Database server window in phpMyAdmin shows the folowing:

  • Server: via TCP/IP
  • Server type: MariaDB
  • Server connection: SSL is not being used
  • Server version: 10.4.6-MariaDB - binary distribution
  • Protocol version: 10
  • User: root@localhost
  • Server charset: cp1252 West European (latin1)

The Webserver window in phpMyAdmin shows the following:

  • Apache/2.4.39 (Win64) OpenSSL/1.1.1c PHP/7.3.8
  • Database client version: libmysql - mysqlnd 5.0.12-dev - 20150407 - $Id:
  • PHP version: 7.3.8

From the above configuration, I understand that the database is MariaDB and not regular MySQL. I do not want to use MariaDB since latest version of MirthConnect is not recognizing MariaDB. I have installed another instance of MySQL (ocalhost:13306). This instance works fine with MySQL Workbench as well as MirthConnect.

When I try using this instance for installing OpenEMR locally, OpenEMR is not able to recognize. Error shown is “Invalid Credentials”

Hi @Arun ,
What version of mysql are you using?

Hi Brady.

Ver 8.0.17 for Win64 on x86_64 (MySQL Community Server - GPL)

Above information was obtained by executing mysqld -V in command line.


Hi @Arun,

Mysql 8 does not work out of box with php unless use following mysql default-authentication-plugin setting:

Screenshot of my.ini from C:\ProgramData\MySQL\MySQL Server 8.0

At the time of installing MySQL 8, I had chosen native password as the default authentication.

Is there any other file that I need to make changes?