OpenEMR 7.0.2 cant add new user

Hi, I’m getting the following error after upgrading to OpenEMR 7.0.2:

“Trying to create user with existing username!”

Kindly assist as we’re trying to add a new employee to the clinic so they assist on the system.

Thank you

@smuglar send screenshot or error log and also please also check if your using existing username to create a new user therefore that error might be showing to you

Hi, I will go to the client and get screenshot… However I don’t know how to get error log, kindly guide me through the process.

Thank you

I forgot to add the following details:

Im using Windows Server 2019 Essentials, XAMPP on a Firefox browser… This happened after upgrading from 7.0.1 to 7.0.2. I will post error log when they open after Christmas holidays…

Hi, Here it is, I also included a screenshot and error log for MySQL. Currently running XAMPP 3.3.0 whuch uses the following:

PHP Version 8.1.1

UBS-admin-09(Remove), molelekwav(Remove), mannathokos(Remove), Ramajap(Remove), MolelekwaT(Remove), JoyA(Remove)

Hi, I responded with what you needed…

Thank you

@smuglar That’s not a mistake. It is saying that a user with that username already exists. Try to add a user with another username.
You can view inactive users in the user list by checking “view inactive users”

Im pretty sure that I haven’t added any other user apart from those but I wjl check the inactive ones and give you feedback… I even tried adding random names and they also gave the same error… I was planning on adding the directly to the database next since using the GUI is failing…

Go to Config Logging User Debug and turn on All then logout the back in and reproduce problem.
If you have any JS or PHP errors they should show on display.

1 Like

Hi, no error logs are showing anything about users be duplicated. Here are the error logs as per your request. I still cant add user and the user needs to get to work ASAP. Im also concerned about the highlighted part that just started appearing after updating from 7.0.1 to 7.0.2

Thank you

access.log (152.0 KB)
error.log (33.8 KB)

Looks like you may have a corrupted upgrade or maybe you have some custom code. Whatever is going on adding new users works in 70.2. Also be sure to follow upgrade guide.

Can I run the upgrade again to try and fix the issue? I had run the upgrade as per the manual on the openemr site (from 7.0.1 to 7.0.2). Some users are also experiencing issues with adding patients so I’m thinking it may be related.

Up to you. Can’t hurt also ensure your user and owner is set after you unzip files.

hi, i have the same problem, but it’s a new installation. I tried the 7.0.2 demo online and local docker with ‘easy development’ image. Same result I can’t add new user

In my opinion when you click add button the system try to update/insert the form data with the Id of current logged user.

1 Like

Does it also show php code at the bottom of the screen when the exception is thrown? I think 7.0.2 is a bit buggier than 7.0.1 from the research I’ve done.

No, the UI interface is clean.

@zerai what user are you using to try and create new users on the demo machines? I can’t seem to reproduce the issue on the demo using the ‘admin’ user.

That error message for password update error occurs when you enter in an invalid password in the ‘Your Password’ field. To create a new user you have to enter in both a password for a user AND your current login password as well. If you don’t you get the error message you posted in the screenshot.

I think your issue @zerai is different than what @smuglar is hitting.

@smuglar you said you’ve thought about adding the user to the database directly. If you look in your users table in the database does it actually show the users you’ve been trying to add?

Can you try adding the users on the demo environment:
Does it work there?

The only thing I see that might be different is you have the warehouse/inventory feature turned on and maybe that’s causing the issue, but I don’t see why that would be. Have anyone added any custom code/modules to your site?

It may have something to do with an option being selected we are not selecting in our testing.
Be nice to know what demo server an issue is reproduced on and maybe we can add that to our doc somewhere.

@adunsulag I used the ‘admin’ user on both case.

when I start the local docker env, there is only ‘admin’
as user in the system.

I havent added the user via the DB as yes but I will be using Hedisql to manipulate the DB… I will check the DB to see if the user exists but I have tried other random names and it doesn’t allow me to add users. The name works on your link, i’m assuming that its 7.0.2 as well… No custom code has been added by the way’ just standard system with addition of certain folders in the file system…