Do you use or administer OpenEMR? Take the General Satisfaction Survey to help improve the product

OpenEMR 6.0 Search Errors

I get this error when searching from Administrator -> Coding -> Codes -> RXCUI Medication

How do I fix this error?

Return error is: Query Error

ERROR: Missing table in code set search:sct_descriptions

C:\xampp\htdocs\openemr\custom\code_types.inc.php at 808:code_set_search
C:\xampp\htdocs\openemr\custom\code_types.inc.php at 453:sequential_code_set_search(RXCUI,Array,1,Array)
C:\xampp\htdocs\openemr\interface\patient_file\encounter\superbill_custom_full.php at 268:main_code_set_search(RXCUI,1,Array)

hi @seddinger, did you load the codes in Admin->Coding->Native Data Loads?

just tested in demo after loading a small weekly file

I can load the weekly codes but not the larger file RXNCONSO.RRF (without license). When I try to upload the larger file, I get this message “LOAD SUCCESSFUL. Codes inserted: 0, replaced: 0”. Not for sure why its not working. I extracted the file from the folder and tried uploading with the zip file.

Yes, I go to Administrator -> Coding -> Native Data Loads -> Install Code Set. When I try to upload the RXNORM_Full file nothing happens then I get the Message “LOAD SUCCESSFUL. Codes inserted: 0, replaced: 0”

prob a php.ini setting, see above post

Can you tell me where to find this?

I removed the record of that old installation using the following:
DELETE FROM standardized_tables_track WHERE name=“RXNORM”;

Thanks for all your help!!

php.ini depends on your webserver, for apache gnu/linux it’s in /etc/php/7.4/apache/php.ini for example

while you’re in there check these settings out

Hi Stephen,

I can’t find this in php.ini file “DELETE FROM standardized_tables_track WHERE name=“RXNORM”;”

Thank you!

ok, what’s your server?

Right now I just have it on test bed which is Windows 10.

Thanks,

Samuel Eddinger

here’s a guide for xampp

Hi Stephen,

Yes, still can’t find this code “DELETE FROM standardized_tables_track WHERE name=“RXNORM” in the C:\xampp\php\php.ini file. If the code isn’t there can be added and if so, where does the code inserted in the php.ini file?

Thanks!

hi @seddinger, ignore that sql statement please, you’re looking for post_max_size and change from 30M to 80M. also upload_max_filesize to 80M and the other settings mentioned in the faq

I changed the upload_max_filesize from 30M to 80M now it works.

Thanks Stephen!