Openemr 6.0.3 with vaccine lot number - system does not save entered number

Problem in openemr 6.0.3 with vaccine lot number - system does not save entered lot number

Hi Folks-
To expand on the OP’s brief note, I’m also seeing a similar problem in an OpenEMR v6.0.0 (3) install.
I enter a vaccine into the panel, with the lot number (1st pic below)
Click ‘Save’, it appears appears in the widget on the pt dashboard (2nd pic)
However, if I click on the immunization entry, the lot number is gone (3d pic)
and in the summary list at the bottom of the screen, (4th pic) the lot number is displayed incorrectly-- here as ‘0’; in other instances (and the OP’s example) it is ‘1’.
This happens not only with test patients and bogus lot numbers but in clinical settings with real patients and real lot numbers.
Thanks- Harley


I still have this problem with version 7.0.1. Demo site shows the same issues. Do we have any updates?

hi @ninjatx , how is it supposed to work? It looks like the lot number is loaded into the dropdown but has to be searched for by typing the first few characters.

When I type in the Lot number and hit Save Immunization, it doesn’t seem to save? Maybe there is a place somewhere else to input the lot number so it will show up in the drop down?

ok, what demo site did you just try?

The lot number, as reported by many users here, seems to be an auto-complete drop down. But, there is no option where the lot inventory can be added or stored as a list. Also, the adde dlot umber doesn’t save on editing the entry.

With the feature rendered unusabe by this, I chnaged the lot number UI control to a simle text field and removed the autocomplete feature. It works well now, and the saving issue is fixed as well.

I can share the code for the fix, if anyone wants it. Can this be added to the OpenEMR code repo? How does it work? Can anyone let me know the steps to do so?


1 Like

Please share the code for the fix. Thank you!

Sorry for the late reply. I will share the code here by tomorrow.