OpenEMR 5.0.1 (7) -> 5.0.2 PHP version Mismatch


(David D. Speck MD) #1

I am attempting to upgrade my current working V 5.0.1 (7) OpenEMR to V 5.0.2, but the database conversion fails with the error “PHP version needs to be at least 7.1.2. under Windows 7.”

I currently show PHP v 5.6.20.0 installed. The PHP upgrade webpage says to use the customized Apache version of PHP.

The current 5.0.1 to 5.0.2 upgrade instructions do not seem to cover a simultaneous Apache+PHP and Oemr Version upgrade.

Any suggestions?


(Ralf Lukner MD PhD) #2

I assume that you are using Windows 7 … is this really true? Maybe tell us a little bit about your setup (server OS, database type and version, etc.).
–Ralf


(David D. Speck MD) #3

Yes, the server is just a Xeon box running Windows 7 with XAMPP and nothing else. I would like to move over to a Linux distro but am not looking forward to the learning curve, and figuring out if a couple of mission-critical Windows apps could be made to run under WINE.

It would be greatly appreciated if someone could post instructions on moving a Windows installation to a Linux based server. I really don’t want to install Windows 10.

The database is whatever was installed by the 5.0.1 upgrade. It seems that the database engine was changed along the way, but I have not found clear explanations of just what changed between MySQL and the MariaDB modules.

The nest step will be to figure out what broke the LBF forms. I can access old records entered with custom LBF forms, but cannot create new instances of these custom forms. I can see their entries in the PHPMyAdmin tables, but cannot edit or implement them. Something didn’t copy over in the 4.X to 5.X upgrade.

I was waiting to see if the 5.0.2 upgrade would restore that functionality before investigating further.