Open EMR v7.0.0 instalation - need help with modules

I’m doing new installation of V7.0.0 from scratch, and have problem with modules. Did installation many times and always the same problem. I reported this problem long time ago, and still cant repair it.
Still can’t resolve this problem because Apache OpenEMR file is missing. All system works fine, but getting problem with modules.

Is there any recommendation, maybe I’m doing some mistake in the installation process

apt update -y

apt upgrade -y

apt install mysql-server php php-xml php-mbstring php-mysql apache2 -y

sudo mysql -u root

CREATE DATABASE openemr;

CREATE USER ‘openemruser’@‘localhost’ IDENTIFIED WITH mysql_native_password BY ‘openemruser123456’;

GRANT ALL PRIVILEGES ON openemr. TO ‘openemruser’@‘localhost’;*

FLUSH PRIVILEGES;

exit

Then go to php settings

Apache PHP configuration

/etc/php/7.4/apache2/php.ini

short_open_tag = Off

max_execution_time = 60

max_input_time = -1

max_input_vars = 3000

memory_limit = 512M

display_errors = Off

log_errors = On

po st_max_size= 30M

file_uploads = On

upload_max_filesize = 30M

error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED

mysqli.allow_local_infile = On

Next, you’ll need to reload the Apache web server for changes to take effect:

sudo systemctl reload apache2

No any recommendations received
Many users got this problem starting from version 6.0.0.
Did re installation many times, and always same problem with modules.
Most likely doing some thing wrong in installation process.

This message for Manage Modules

did you add this to apache.conf ?

And after that :
sudo a2enmod rewrite

then restart apache2?

1 Like

As we’ve mentioned in previous posts. The error is occurring because the apache rewrite command is not being processed by the apache software package. Either your mod_rewrite module is not enabled, or the .htaccess file inside the modules directory is being blocked with whatever mechanism you used to install apache.

If this continues to be a blocker, you should try one of the other OpenEMR installation mechanisms (such as docker, aws package) or hire someone to help assist you in resolving this issue.

1 Like

@Mohammad I did , and nothing changed. Thank you for your recommendation.

Thank you @adunsulag for you replay. I just mentioned before, there is some problem in installation process from the beginning. A lot of users experiencing this problem after upgrade started to 6.0.0.
That why I posted step by stem installation, to check if I miss some thing.

The are missing dependencies, you will need to install NodeJS, and follow the build instructions in the README.md included with OpenEMR.
Also make sure that your Apache2 site configuration includes the necessary parameters to allow overrides and the Apache2 rewrite module is enabled, since the module URLs are generated dynamically.

1 Like

On Ubuntu server (virtual), I had the same error, but it worked by placing

<Directory "/var/www/html/openemr">
       AllowOverride FileInfo
       Require all granted
   </Directory>
   <Directory "/var/www/html/openemr/sites">
       AllowOverrideNone
   </Directory>
   <Directory "/var/www/html/openemr/sites/*/documents">
       Require all denied
   </Directory>

in /etc/apache2/apache2.conf.
Even though I had the same thing in openemr.conf

2 Likes

Maybe…
You now need to change the ownership of the directory.
Use the chown command and R flag to set the owner of all files and the group associated with openemr to www-data:

sudo chown -R www-data:www-data /var/www/html/openemr

2 Likes

These are my steps that I used when I set it up:

sudo nano /etc/apache2/apache2.conf

Below <Directory /var/www/>, make sure to change AllowOveride to All and Require all granted like this:

AllowOverride All
Require all granted

Save the file, then use these commands:

sudo a2enmod headers

sudo a2enmod rewrite

sudo systemctl restart apache2