OEMR 5.0.1installation hangs in step 3


(Tomáš Vilhelm) #1

Hello friends,
I have experienced strange behaviour io installer. Installation process hangs in step 3 . I tried it many times in other browser as well. But without success.
My config is Debian stretch , php 7.2, apache , mariadb,
Can you advice me soem solution ?


(Stephen Waite) #2

hi @Tomas_Vilhelm, do you see anything in the php error log? /var/log/apache2/error.log


(Tomáš Vilhelm) #3

Log is here:

[Mon Jul 15 07:45:08.158562 2019] [php7:notice] [pid 8558] [client 127.0.0.1:37408] Using older mysql version method to set password for the mysql user, referer: http://localhost/openemr2019/setup.php?site=default
[Mon Jul 15 07:48:44.067045 2019] [php7:error] [pid 8558] [client 127.0.0.1:37408] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/html/openemr2019/library/classes/Installer.class.php on line 631, referer: http://localhost/openemr2019/setup.php?site=default
[Mon Jul 15 08:14:07.828727 2019] [php7:error] [pid 21054] [client 5.188.210.101:49131] script ‘/var/www/html/echo.php’ not found or unable to stat, referer: https://www.google.com/


(Stephen Waite) #4

here are the preferred php settings


(Tomáš Vilhelm) #5

Thanks a lot …I will try. Regards Tomas


(Tomáš Vilhelm) #6

Solved by switching to php 7.3 and php.ini update…Thank you