Read about OpenEMR's Response to the COVID-19 Pandemic at https://www.open-emr.org/covid19/

Notice: Undefined index: language_direction

Situation
I a getting this notice Notice : Undefined index: language_direction in C:\xampp\htdocs\hms\src\Core\Header.php on line 149 on the login page and when i login the interface is blank

OpenEMR Version
Most recent version as of writing this

Browser:
I’m using: Firefox and running it locally using latest XAMMP

Operating System
I’m using:

Logs
Did you check the logs? Was there anything pertinent in them? Paste them here (surround with three backticks (```) for readability

hi @Golden_Nguluwe, did you disable notices? https://www.open-emr.org/wiki/index.php/FAQ#What_are_the_correct_PHP_settings_.28can_be_found_in_the_php.ini_file.29.3F

Let me check will get back to you

I am also having the same issue, and I have the correct setting on php.ini file

Really need help on this !!!

Has anyone come up with a fix on this please?

hi @arvindjeenoor, fix is above Notice: Undefined index: language_direction

To be more specific, In php.ini, you must set display_errors and display_startup_errors to Off. It seems you might’ve done this on accident when setting up PHP – this shouldn’t be turned on unless you know what you are doing. If you purposely turned this on, please add to the error_reporting variable ~E_NOTICE to remove notices.