Maintenance of Ubuntu 16.04 with OpenEMR 4.2.2

question

(Aaron Chantrill) #1

Is there a known issue why a system administrator would not be able to apply patches to an Ubuntu 16.04 server since March 2018 due to incompatibilities with OpenEMR 4.2.2? When I asked for documentation of the issue, I was told to look online.


(Stephen Waite) #2

hi @aaronchantrill, patches are for the most recent release, after upgrading to 5.0.1 and then running the latest patch you’ll be running 5.0.1.7

although maybe you’re asking about applying ubuntu updates to 16.04 that might affect v4.2.2? you should be fine since v4.2.2 package is compatible with php 7, as listed on readme


(Aaron Chantrill) #3

No, I’m asking about an IT vendor not patching the operating system itself because they say updates to Ubuntu 16.04 are not compatible with OpenEMR 4.2.2.


(Stephen Waite) #4

see my edited post please

always good to test it out first though


(Aaron Chantrill) #5

Thank you.

I have installed OpenEMR 4.2.2 on a variety of linux flavors, and the only thing I’ve ever had to do was update the adodb interface file, but not on Xenial. I can imagine there might be slight incompatibilities from 16.04 to 18.04 but nothing that should take more than a couple of hours to sort out. Ubuntu is not my favorite flavor, but I have installed OpenEMR on a fully patched Xenial before and never noticed any issues, but I also have never deployed that to production.

I am developing a testing plan right now, and there is a dev/training server that I can apply all the updates to first, but since the vendor says it’s “well known on the internet” I figured I’d check with the source. The vendor is supposed to be responsible for updates.

Thank you for responding.


(Stephen Waite) #6

would expect that 4.2.2 has only been checked out with early php 7.0.x releases from late 2015 or early 2016