Linux Mint 20 instalation

Trying to reinstall OpenEMR 5.0.1 Ubuntu-Debian Package Installation with PHP7, on new Linux Mint 20.0, but have a problem with a installation

Screenshot from 2020-09-23 19-57-18

I tried again to start installation from OpenEMR 5.0.1 Ubuntu-Debian Package Installation with PHP7, and then upgrade to 5.0.2, because with new installation of 5.0.2 I always have a problem in setup process.
I just did step by step installation on Linux Mint 20, a got stock again


Have you tried changing the necessary permissions to the folders.

chown -R apache:apache directory_name
(depicted in the image).


Yes I did, but I’m not sure if I input correct apache direction - apache2.

I didn’t had any problems with previous versions of the Linux Mint, but can’t make any installation on Linux Mint 20.0, maybe it’s not compatible yet?

Do you have all the dependencies? It looks like you are missing php-gettext

Hi @ncavalier ,
The OpenEMR ubuntu package is basically not compatible with ubuntu 18.04+ (one of the reasons it is no longer supported in OpenEMR 5.0.2+ ).


Just to confirm, OpenEMR 502 is not compatible with Ubuntu 18.04+? So if users of OpenEMR need to stick with Ubuntu 16.04 and never upgrade?

No, the ubuntu package is not compatible.

But I’m using now 5.0.2(4) on Linux Mint 19.3 with Ubuntu 18.04.
Is it mean that OpenEMR 502 is compatible with Ubuntu 18.04., and not compatible with Ubuntu 18.04+?

hi @ncavalier, we’re talking about 2 separate things here.

  1. OpenEMR 5.0.2 will run on Ubuntu >= 16

  2. The OpenEMR 5.0.2 package (installed through the Debian/Ubuntu package management system) is still under development.

Thank you for clarifying. I have been running 502 on several systems using 18.04 and I had a slight heart attack, but no big deal :slight_smile:

The process that I have been using forever is keeping the git repo separate from the live version, and running an upgrade script when I make custom changes to the base code. The base code gets updated (ignoring the sites/ directory) when updates to the code happen or when I make custom changes.



OK. If you have OpenEMR installed and if you didn’t use the package, there is a good change that you don’t have all the dependencies installed. You will need to install and enable the dependencies.

The reason I’m trying to reinstall, because we experiencing problems with posting secondary payments.
We using 5.0.2(4) with php7.2, and trying to upgrade to php7.4, because there is updated setting to resolve posting problems.
We trying to update php7.2 settings to recommended
upload_max_filesize = 32M

post_max_size = 48M
memory_limit = 256M
max_execution_time = 60
max_input_vars = 3000
max_input_time = 1000,

and after update, we got another problem, batch posting not working at all

when we input payment information, Payment amount not showing on Undistributed, and after pressing Save changes button, its not saving and going to new screen

I changed browser from Firefox to Google Chrome and now the problem partially resolved, we can input payment amount, but when we start posting secondary claims payments, its going to blank screen or to new payment screen

Now we can save payment info and start posting

When we press ok to Post Payment, its going to new payment screen

Hi @brady.miller
We had conversation last year about new version of Linux Mint20 for v5.0.2.
I"m just checking, if there is any changes for v6.0.0(3) if it’s compatible with latest version of Linux Mint20

hi @ncavalier ,
That will very likely be dependent on the PHP version in that OS. What is the default PHP version used in that OS?

The PHP 8.0. 2 is installed on Linux Mint 20

hi @ncavalier , 6.0.0(3) should be compatible with PHP 8.0, so should work fine on Mint 20.

Thank you @brady.miller for your replay.
Will try to update my computer to new OS Linux Mint20, and install V6.0.0(3) on it.
Will let you know how it works.